Matag fridge not cooling

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
I've obtained (free and in almost new shape) a Matag MFD2560HEW. The guy i got it from said the freezer works fine...but the fridge area doesn't cool. The unit is about 3 years old now

The original owner said he had a power surge??? called Matag.

Matag replaced the compressor/condenser... still not working... They gave him a complete new fridge and left the old one.
The guy wasn't sure but the matag guy said something about a bad wire inside the fridge case and that they don't go that far.? (to lazy or cost effective to fix?)

I've had it plugged in for about an hour and the freezer seems to be getting cold but with no cold air coming into the fridge area... the damper is working, using the service mode.

When i feel inside the freezer area... seems cold air is coming out of the lower slotted area (on the backside) but not the larger vent on the top backside.


The compressor and compressor fan seem to be running fine!

I've read a lot of post about the defrost control board being the problem, but none of the posts are about this specific model.

Thank you, (in advance)


Randy
 

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
Update to previous post "not cooling"

The freezer is freezing... but I don't think in the proper way.
The back wall of the freezer is frosting up. Still no forced air from with the freezer vent or the refridgerator vent.

Randy
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,374
Location
McMullen Valley, Arizona
So you don't hear the freezer fan running in your freezer blowing cold air down to your refrigerator section?

Put a thermometer or a cup of water in your freezer and see if it freezes and see what the temperature is.

Jake
 

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
No fan noise

There is no freezer fan noise. There is no cold air coming from the freezer vent and no cold air going up to the fridge area.

I don't have a thermometer for testing but after a couple of hours a cup of water will begin to freeze.

Also the back wall of the freezer is frosting up.

Thanks again,
Randy
 

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
evaporator fan not running

I put the unit into service mode. Tested for evaporator fan on/off = nothing.
No clicking or anything, no fan noise.

Is the ev. fan located behind the back wall of the inside of the freezer? I can test for voltages etc.

Also.. I've read where stock Panasonic fans fail and should be replaced with an after market (better model) fan... (if this is the problem)

Also could it be in the control unit ie:not telling the fan to come on etc.?

Also... the cup of water in the freezer froze solid :}

Thank you,
Randy
 

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
Update to fan problems

I dug the evap. fan out...

Then hooked fan up directly to 120vac nothing, it will not run.

I bought a new fan from a local supplier...

The fan still insist on not coming on.

Voltage from fan plug, while fan is not plugged in is 113 vac or so. (line voltage from the house is always about 120vac)

Then I connected fan directly to a 120vac line cord and it works fine.
In checking the voltage on the fan while everything is connected
I get min. voltage (.06 or something) with no fan movement at all.

Could this be a problem pointing to the control board or a wire problem?>

Thanks again,
Randy


PS... all the service mode tests for everything test good.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,374
Location
McMullen Valley, Arizona

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
Working fridge

I replaced the controller board and everything seems to be running fine...
But I need the code for the controller board
The docs say it should be on a sticker along with the mod/ser number... well
I can find the sticker with the mod/ser... but it doesn't say anything about a code number (like in the doc pics).

I've set it to code 2.0 and it seems to be running fine...
I can adjust temps via the board settings but it seems to be running to cold.
I just need to know what code this fridge is...
mod mfd2560hew

Thanks again,
Randy
 

randyinwa

Premium Member
Joined
Feb 11, 2007
Messages
8
Location
Washington
No code

I found where the sticker WAS, inside the top right fridge area... but the service person must have removed it.. when they replaced the whole unit...
Now I'm really stuck... :{

Thanks
Randy
 
Top