• Please note, some of the links on our site are affiliate links (Learn More)

Maytag Dishwasher MDB8989SHZ filter cover loose

jrkmo1

Premium Member
Joined
Jul 2, 2018
Messages
37
Location
St Louis
Model Number
MDB8989SHZ
Brand
Maytag
Age
1-5 years
I have a Maytag MDB8989 and took off the metal and plastic filter covers to clean the filter and strainer. No problems, except when I went to put the plastic cover back on, it is no longer keeping a tight seal with the rim.

So when the metal cover goes over the top, it is now causing the spray arm to rub when it revolves. So far the dishwasher is cleaning properly. I only noticed it because I gave the arm a spin when I put the cover back on. There's no other way for the covers to go on, so I know they are on properly. But now there's a tiny gap that pushes everything up just a bit, and causes the rubbing.

Is this something to worry about? Any tips on something I may have missed? See pic below.
 

Attachments

  • 20210120_170916.jpg
    20210120_170916.jpg
    146.5 KB · Views: 20

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
41,156
Location
Murray, Utah 84107, United States
Doesn't sound like it's installed properly. I'm not sure what you're showing me in the picture.
 

jrkmo1

Premium Member
Joined
Jul 2, 2018
Messages
37
Location
St Louis
Just trying to show the parts I'm talking about for reference. There's only one way these two pieces fit.

My concern is that the plastic piece maybe bent a tiny bit when pulling it off. Everything snaps back into place. It just sits a tiny bit higher than before. Not noticeable to the eye.

Long term, I'm just worried that it'll create an issue. Trying to get info on whether or not it will.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,045
Location
McMullen Valley, Arizona
I just found a video that should help, make sure those metal tabs are in place properly on the accumulator cover.:)


Let us know how it goes.

Jake
 

jrkmo1

Premium Member
Joined
Jul 2, 2018
Messages
37
Location
St Louis
Thanks Jake. That's actually the video I watched in order to see how to get to the filter. All of the metal tabs are in place. The issue is that the accumulator cover isn't resting flush against the tub. It's only like a mm off, but that's enough.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
41,156
Location
Murray, Utah 84107, United States
the plastic piece maybe bent a tiny bit when pulling it off.
You should be able to bend it back or just leave it like that if everything is working OK.
 
Top