maytag gas range

Reg

Premium Member
Joined
Jan 18, 2006
Messages
5
Location
Alberta
just curious if anyone has one of these, as when we turn our oven on it works fine, only we get a very strong smell of gas in the kitchen right after ignition. My brother and other friends have gas ranges and have never noticed this strong a smell. We have a Presicion touch control slide in 800, that is what it says on the manual. Love the look, love the way the controls are set up, and the layout of the top, just hate the stink when we use the oven. Hard to explain the strength of the smell in words but if you stand in the wrong spot it feel strong enough to give a person a headache. I am thinking the ignitor or heat coil whatever it is that lights it is not really ready when it lets out the gas. It really sucks when you purchase what you believe is better or higher end stuff, at least in their brand it is higher up and then have this trouble. Of course the first thing any says is well its a gas range you can expect some odor, which is true but to think your gonna blow up your kitchen is a bit excessive. Anythoughts are appreciated. Thank you

Reg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,364
Location
McMullen Valley, Arizona
Does it seem to take a long time for the igniter to lite the gas when you start the oven?

Jake
 

Reg

Premium Member
Joined
Jan 18, 2006
Messages
5
Location
Alberta
I reread your question and it does not seem like an excesive amount of time to light after I see the glow get bright. Once I hear something happen it seems like its lit. I am not sure exactly when the gas is dicharged, I can hear it then I would have to say the fire start immeadiatly.

it probably takes 10 secs I am guessing before I can see it glow maybe less, I could check. I checked and yes its about 10 sec then another few sec till I can hear the gas discharge. Then I get a pretty good wiff of gas. It must dump alot in right off the bat or something.

Reg
 
Last edited:

Reg

Premium Member
Joined
Jan 18, 2006
Messages
5
Location
Alberta
well afte doing that test my wife came home and went into the kitchen and gasped as she thought someone left the stove on or something, I went out of my office towards the kitchen and the smell is strong. I don't want to have to return this stove, I hate dealing with that kind of thing. hoping for a solution, thanks again for the time.

Reg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,364
Location
McMullen Valley, Arizona
It sounds like its liting ok, how old is the range?

Have either the gas company come out or an appliance company to check it.

Jake
 

Reg

Premium Member
Joined
Jan 18, 2006
Messages
5
Location
Alberta
Its brand new, and gas is new to us. I did some checking, I took the bottom tray out so I could see the emement and lit it. It seems like the gas comes in so hard that it can't burn it. It won't light the whole element at the same time. I turned the broil one on and it lites nice and even, granted the broil one is probably smaller btu or whatever but maybe its a regulator problem. I wonder if they can be ajusted or are set at factory. I am going to now get the store to send out a repair guy to have a look. I am just a fix it myself guy or at least find out whats up guy so I am trying to get educated a bit. I also thought maybe the bottom element needs the cover on it so it can burn as it should. So I put it back on and of course then could not visible see what was happening but I could hear it, and it sounded the same like the flame was all over the place. Does this make any sense?

Reg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,364
Location
McMullen Valley, Arizona
Yea, it sounds like the repair guy will be able to make a minor adjustment with that glow bar igniter, possibly adjusting it closer to the burner, so it will lite faster and smoother.:)

Jake
 

Reg

Premium Member
Joined
Jan 18, 2006
Messages
5
Location
Alberta
Actually I figured out what was up. I had to close down the air intake so the gas could actually get a good burn. It works 100% now and my wife is happy and everything is good. Love the range they just leave the open quite large at the factory.

Reg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,364
Location
McMullen Valley, Arizona
Good job in finding what was wrong Reg and fixing it!:)

Thanks for the update.

Jake
 
Top