• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Maytag MEDB850YW electric dryer heater relay has 0V between red and black when running, and has no heat

Status
Not open for further replies.

chasbirder

member
Joined
Apr 9, 2022
Messages
7
Location
South Carolina
Model Number
MEDB850YW
Brand
Maytag
Age
6-10 years
MEDB850YW Maytag Bravos XL dryer stopped heating three days ago. Running diagnostics showed an F4E4 code, and install diagnostics was L2. I confirmed the circuit breaker was 240, and the outlet was 240. I ran without any vent hooked up and still no heat. I then followed the service technician instructions for CCU power tests and everything was correct. (Attached the tech sheet so you can see what I was following).

I found this thread
It seemed to make sense, so I tested the heater relay as well. The black L1 from the heater relay had 120 V to P8-3 when off, and when when running timed dry high heat, there was 120V from red to P8-3, but there was 0V between the black and red on heater relay when timed dry high heat was running.

I posted this to that old thread, but then realized it would be best to start a new thread.

It is my understanding that this means the relay is toast (right? since I know each has 120V but not 240 between them?), and I'll need to replace the board?

Big thanks to everyone.
 

Attachments

  • Tech-Sheet-W10393006-Rev-B.pdf
    8.3 MB · Views: 76

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Did you first unplug the dryer from the wall outlet and ohm test the thermal cut-off and high limit thermostat and heater? Look on page 22 at the wiring diagram where the heater relay COM goes too.

Here's your parts diagram:
#14 is the heater
#47 is the thermal cut-off
#48 is the high limit thermostat

Here's the control board for your model:
WPW10432257 Electronic Control Board


Jake
 

chasbirder

member
Joined
Apr 9, 2022
Messages
7
Location
South Carolina
Thanks Jake, I hadn't gone below yet. Across the thermal cut-off and high limit thermostat and heater I am reading ~1-2 ohms (between each is the same), and as a followup, in on the CCU am reading 10 ohms between P4-3 and P4-6 (p 15) test.

I am going to be honestly ignorant and not sure what this means about what part is actually broken. Big big thanks for your help and time.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Yes, I always ohm test those parts first I posted above before I replace the control board.

Make sure your dryer is unplugged from the wall outlet first before accessing and ohm testing those parts.

Jake
 

chasbirder

member
Joined
Apr 9, 2022
Messages
7
Location
South Carolina
Pretty sure 1 ohm across all three means they are electrically open, right? Which according to the manual (from page 14 first post, and below) this means I need to replace the heating element but everything else is good? Just need to know since I’m going to order them and then leave town for a few days and need to fix it when I return.

Again, thank you.
 

Attachments

  • 038FA220-D8AD-4899-955F-4C0AF0B229C9.jpeg
    038FA220-D8AD-4899-955F-4C0AF0B229C9.jpeg
    118.5 KB · Views: 70

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona

chasbirder

member
Joined
Apr 9, 2022
Messages
7
Location
South Carolina
Thanks for your patience Jack. I didn’t know you calibrate the miltimeter first. Anyways, unhooking then testing heater fuse and thermostat, both read 0 ohms. Unhooking and testing heating element it doesn’t read anything. So heating element is bad?
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Ok sounds good, yes keep us posted.

Jake
 

chasbirder

member
Joined
Apr 9, 2022
Messages
7
Location
South Carolina
Replaced the heating element Sunday night, and checked resistance everywhere again before re-assembling, and it looked good. Turned it on and the dryer was heating again!

HUGE thanks Jake! Really, thank you.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Excellent, glad to hear the new heating element fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top