• Please note, some of the links on our site are affiliate links (Learn More)

Maytag Pgr5710bdw

74mg

Premium Member
Joined
Oct 6, 2007
Messages
4
Location
mass
When I set the oven to temp , after a minute I can smell gas.Then about a minute later I hear a load puff. Like you would get when lighting a BBQ. The stove always worked great but the smell of gas and the time it takes to ignite is not right.Sounds like a setting thing to me, but would like some advice ( so i dont blow up the house :eek: )
 

Pegi at Sams

Appliance Tech
Joined
Oct 30, 2005
Messages
954
Location
Wichita Falls, Texas USA
Sounds like your igniter, Ref. #9 in this breakdown has gotten weak, is taking too long to open the gas valve so the gas is coming out too slow and causing the explosion and the gas smell, I would replace this igniter before you blow the oven/house up....:rolleyes:..if replacing the igniter does not solve the problem then you would also be replacing the gas valve itself....I have not seen the valve be the problem except on one range, it is usually a weak igniter causing this problem.
 

74mg

Premium Member
Joined
Oct 6, 2007
Messages
4
Location
mass
Pegi, thank you, I opened the bottom of the oven and it seams the igniter is glowing right from the start. Does this change things?
 

Pegi at Sams

Appliance Tech
Joined
Oct 30, 2005
Messages
954
Location
Wichita Falls, Texas USA
All the time or when you turn the oven on to heat? If when you turn the oven in for heat then yes this is correct, the igniter starts to glow, when it gets hot enough and draws down to the amps posted on the gas valve the valve will then open, this should take 1-2 minutes....and that igniter then stays on to hold the valve open, when the heat cycles off the igniter cools down which then closes the gas valve....watch and see what it is doing, should not be any gas escape unless the gas valve is too slow to open or close...
 

74mg

Premium Member
Joined
Oct 6, 2007
Messages
4
Location
mass
Pegi, here's whats going on. set oven to 350, hear a click the igniter starts to glow.about 25 seconds into it i smell gas.@ about 1 minute the flame starts. through out the heating the igniter stays on until it reaches temp. I hear a virbration ( fluttering) for about 7 seconds then off for 15 seconds and continues on that same pace until the oven comes to temp.this is with the door open a little. If I close the door the same thing happens but the smell of gas is even more.
 

Pegi at Sams

Appliance Tech
Joined
Oct 30, 2005
Messages
954
Location
Wichita Falls, Texas USA
Well what I do know the igniter and/or the gas valve can cause what you are seeing, do not know which one or both are the problem, could start with the igniter as it costs less, but to be sure would have to replace both....I do not know what to tell you to do for sure...perhaps others can shed their ideas in what they would do....at this point I would replace the igniter, and if it still did this I would replace the gas valve...this is what I would do, I cannot tell you what you should do....:cool:
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,005
Location
McMullen Valley, Arizona
Yes, I agree with Pegi.

9 out of 10 times its your oven igniter causing this issue.

Here's the one for your model:
Manufacturer part#74007498 is RepairClinic item#949510


If you purchase parts from our links here and you install them and it doesn't fix the problem, you have a 365 day full refund on them.

Jake
 
Top