• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Maytag Refrigerator MFI2569VEM4 - Acted strange for a few weeks then quit working

PMCNCTech

Premium Member
Joined
Jan 7, 2022
Messages
4
Location
North Carolina
Model Number
MFI2569VEM4
Brand
Maytag
Age
More than 10 years
For the past few weeks this unit has occasionally taken multiple attempts to start the cooling cycle. I could hear it attempt up to about 7 (guessing) times but would finally start and would hold temp. Later I noticed that, during these attempts to start, the lights on the front panel would blink as it attempted to start. Today it does almost nothing. If I unplug and reconnected to the outlet, I can hear the ice door close but I see no lights at all. When I was doing this I could not see the display and reconnect to the outlet at the same time. So I can't say that the ice door is the only activity. But if I press any button on the control panel, everything lights up while the button is pressed - no other activity at all.

Searching my model # brought me to this forum and it seems that there are a pair of boards that cause issues on these, one in the door and one at the back. Based on these symptoms, anybody care to guess which board is the most likely suspect? Or, could it be something totally different?
 

PMCNCTech

Premium Member
Joined
Jan 7, 2022
Messages
4
Location
North Carolina
After more reading, I checked the incoming 120V and outgoing 12V on the main board and I do have 12V out. So I am guessing the board in the door is most likely.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
128,926
Location
Redmond, Oregon
No, you need the main control board in the back.

Here it is for your model:
Electronic Control Board WPW10312695


Look here:
That Whirlpool in that thread is identical to your Maytag. Whirlpool owns Maytag.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
128,926
Location
Redmond, Oregon
Ok, sounds good, yes its good to have a spare refrigerator.:)

Let us know how it goes.

Jake
 

PMCNCTech

Premium Member
Joined
Jan 7, 2022
Messages
4
Location
North Carolina
I think the problem has been solved with the new board. It has been operating for at least a day with the new board installed and no failures have been seen. Thanks for the info.

Is there any value or repair potential in the old board?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
128,926
Location
Redmond, Oregon
Excellent @PMCNCTech glad to hear the new main control board fixed it.(y)

Thanks for the update!

Is there any value or repair potential in the old board?
Not that I'm aware of. You can take it to a ecycling place if you have one in your area.

Jake
 
Top