• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Maytag Refrigerator MFX2571XEB2 Water Issues

Craven

Premium Member
Joined
Oct 9, 2009
Messages
5
Location
Iowa
Model Number
MFX2571XEB2
Brand
Maytag
Age
6-10 years
Having issues getting the water dispenser and the ice maker to work. It's a Maytag MFX2571XEB2. I've replaced both water valves (the main one where the water connects and the one inside that splits off to the door and the ice maker). When the water dispenser button is pressed, the main water valve is working and supplying water up to the inside valve. If I unplug the connector going to the drinking water valve and press the button, I'm getting 120v across the 2 terminals. However if I plug it back in and press the button, I'm getting 0v. I'm guessing the ice maker is doing the same thing.

Hoping someone can point me in the right direction from here.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,963
Location
McMullen Valley, Arizona
It sounds like have what's called ghost voltage, its like you have a bad neutral connection, but I've never seen this happen on a refrigerator that's 120 volts. I have seen this happen on 2 dryers where its 240 volts.

Look for a broken or shorted neutral wire in your water inlet valve wire harness.

I'm attaching your wiring diagram below, the WH(white) is NEUTRAL. You can see from the SMART VALVE P1-2 YL and P1-3 TN goes to the WH(white) NEUTRAL side.

Jake
 

Attachments

  • techsheet-w10341191-revb.pdf
    298.1 KB · Views: 27

Craven

Premium Member
Joined
Oct 9, 2009
Messages
5
Location
Iowa
Jake,
You sir are a lifesaver. I traced the neutral back using the schematic, and somehow, in the connector up in the light housing, one of the white wires has wiggled out just enough that it was no longer making a connection. No idea how this happened. Saved me buying a new fridge.

Thanks again!!!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,963
Location
McMullen Valley, Arizona
Excellent @Craven glad you found the bad neutral and fixed it.(y)

Thanks for the update!

Jake
 
Top