• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Maytag Refrigerator MSD2556AEW not coming on

litjoe

Premium Member
Joined
Aug 20, 2009
Messages
8
Location
tennessee
Model Number
MSD2556AEW
Brand
Maytag
Age
More than 10 years
refrigerator side this morning 58 degrees freezer side 9 few years back had this to happen evap coil was frozen opened up and thawed did not do it again for months next time it did it i replaced adaptive defrost board. havent had a problem for years. this morning compressor was running not excessively hot just warm .

thawed cut back on evap fan and condenser fan and compressor was running. thought may have to change defrost board if it did it again. went back in 30 minutes everything had shut off.

unplugged unit and plugged back up everything tried to come on for a slit second then shut off. i unplugged compressor same thing. both fans cut on for second then cut off.

i am wondering if it has stuck in defrost. didnt check amps on heater had to take mom to dr. i fell like its something i did when i thawed it. but it did come back on right after i thawed it. i know it all ran for a few minutes. i am a hvac tech not appliance any help would be great. MSD2556AEW
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,822
Location
McMullen Valley, Arizona
When you saw it at 58 yesterday morning was the freezer evaporator coil completely frosted up?

Now the compressor and fans do not stay running at all? If that's the case either your temperature control thermostat is going bad or your adaptive defrost board is going back again.

You'll need to check the temperature control thermostat to make sure it has continuity when its on. Unplug your refrigerator first before ohm testing it with an ohm meter.

Or you can jump the wires on it just to test to see if it comes on and STAYS ON.

Here's the temperature control thermostat for your model:
WP61005516 Control Assy., Temp.


If that tests good, then the problem is your defrost board AGAIN, and its NLA.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,822
Location
McMullen Valley, Arizona
How did find that out? What did you do to the board to make it stay running?

Jake
 

litjoe

Premium Member
Joined
Aug 20, 2009
Messages
8
Location
tennessee
jake i had a adaptive defrost board that i bought 10 or11 years ago i knew that it happen while i was thawing evap coil 90 positive ice maker had over flowed and made coil ice up blocked with ice not frost i had had this happen before.

so checked outage on board did not have voltage to compressor. when i pluged it in everything tried to come on for a second then lost voltage out of dfb.

so i changed it. this is the second or third dfb i have put on this fridge in 20 years. doing heating and air work had several robertshaw i think zone boards that after they had been in for several years if you powered them off they would not come back up. had to replace
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
123,822
Location
McMullen Valley, Arizona
Got it!

Thanks for letting us know.:)

Jake
 
Top