• Please note, some of the links on our site are affiliate links (Learn More)

MDB7749SBM3 Maytag Dishwasher no lights

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
Model Number
MDB7749SBM3
Brand
Maytag
Age
6-10 years
I delayed the start of the dishwasher to run over night. The next morning, there was some standing water, and no power, no lights. Could this be caused by a faulty high limit thermostat? If not, what are some other possibilities?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,133
Location
McMullen Valley, Arizona
Let's go back to 2017, when you posted this here:
What did you find about the drain pump? What fixed it then?

Jake
 

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
The drain pump. However, this time the control panel is completely out. The last time, we had lights.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,133
Location
McMullen Valley, Arizona
Got it! Thanks!

Lets first check the door switch. Check the resistance of the door switch with a multimeter. Should be less than one ohm. High ohms=bad switch.

Here's the door latch switch assembly for your model you can order if yours is bad:
Door Latch WPW10653840


There is a video in the door latch switch part link that shows you how to remove it and replace it.

Jake
 

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
Jake,

I was going to check that, but I found this: This was the control panel. That didn't look good to me. I replaced that.
What is the piece that the white connector goes to? It's also got burn marks on it.
What in the world could have caused this? I have read where others have had issues with the control panel. Is this a bad model?
 

Attachments

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,133
Location
McMullen Valley, Arizona
Yup, you found the problem.

Here's the control panel for your model you can order:
W10811169 Panel-Cntl
whirlpool-panel-cntl-w10811169-ap5985062_01_m.jpg



Jake
 

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
I have replaced that, but the piece that the white cable connects to is also burnt. What is that?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,133
Location
McMullen Valley, Arizona
Got it!

That's the wire harness, you will need to order and replace that too if its burnt as well.

Here it is for your model:
Wire Harness


Jake
 

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
The next part in the chain. The gray box that the wire harness plugs into. It sits behind the front cover.
 

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
I think so. I replaced just the control panel with no luck. The control board has burn marks on it. Have you ever seen both burnt?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,133
Location
McMullen Valley, Arizona
Nope, that's the first I've seen both get burnt in my 33 year appliance repair career.

Jake
 

dad004

Premium Member
Joined
Apr 13, 2017
Messages
10
Location
Camden
Would the control board be the next thing to try? Or is there something else I should check?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,133
Location
McMullen Valley, Arizona
Yes, replace the control board too, sorry I forgot to mention that in my last post.

Jake
 
Top