• Please note, some of the links on our site are affiliate links (Learn More)

FIXED MDB8959SAS0 Possessed Maytag Jetclean - beeping noise, wonky control panel

Status
Not open for further replies.

larsinaz

Premium Member
Joined
Dec 19, 2013
Messages
4
Location
az
Model Number
MDB8959SAS0
Brand
Maytag
Age
1-5 years
Just going to share as much info as I can. Not sure what might be relevant.

We purchased this dishwasher about 18 months ago from Home Depot on our Home Depot Card.

A few weeks back, we ran it through a typical cycle (quick wash/no heated dry). Several hours later I heard a faint beeping noise. I traced the beeps to the dishwasher and noticed it was not running but the heated dry light was on. I opened the door and sure enough, lots of heat came out. I think I hit cancel and the heated dry light came back on right away. Cancel again, heated dry light returned. All the while intermittent beeps... no pattern at all. Finally I unplugged it and plugged it back in. This seemed to do the trick until the next time we went to use it. It finished the cycle, more beeps, forced itself to heated dry. The next time we used it, it finished it's cycle fine but completely died. Unplugging it didnt do anything. Hitting combinations of control buttons didnt do anything. No reaction at all from the control panel.

So I did some searching and found other people having similar problems with the control board inside(not the panel with the buttons). I decided to purchase a new main control unit and installed it. Everything worked fine on it's first cycle. The second cycle, the beeping started again. I pressed cancel and the quick wash button chimed and lit up and more intermittent beeps. Right now, it's sitting unplugged.


Our dishes are typically very clean going into the washer as we basically rinse off all food so this is the reason we run quickwash cycles. Also, the heated dry option seemed to make our dishes stink and we live in Arizona (where everything is hot and dry already) so we rarely ran it with that option. When we did run on normal cycle, it always ran for hours... 2 or more (not sure if that is normal).

Any ideas or thoughts?
 
Last edited:

mshas

Premium Member
Joined
Jun 20, 2017
Messages
2
Location
Ontario
Hi, We are having issue with Beep from the Clean/Drain button for the same model. It started 2 days back. We took the power out and back in. Then pressed the clean button. After a minute it beeps again and some noise from inside the washer. After few seconds clean/drain button keep flashing again.

Thanks
 
Last edited:

larsinaz

Premium Member
Joined
Dec 19, 2013
Messages
4
Location
az
Just got an email notifying me of a reply to this thread I posted like 3 years ago.

So here is an update on our dishwasher:

Since that time, our dishwasher got even more temperamental and would require frequent unplugging/plugging back in or sometimes I would actually have to take the door apart and unplug the control panel and/or control module then plug them back in. One of those items would usually fix it for a few days but it eventually quit responding at all to any of our temp fixes. I got lots of practice and could have the door apart and back together in less than 5 minutes.

I bought a new control panel part # WPW10475780
It did the trick... washer has been working as expected since that time. Quick and easy fix but requires torx bits to get the door apart.

Thanks Rick, you were spot on!
 
Status
Not open for further replies.
Top