• Please note, some of the links on our site are affiliate links (Learn More)

MED302JS/04 Thermador Wall Oven Dead No Display Need Help!

ApplianceBCS

Premium Member
Joined
Aug 20, 2022
Messages
52
Location
College Station, TX
Model Number
MED302JS/04
Brand
Thermador
Age
6-10 years
Hello I own a appliance repair business in Texas and want to see about thoughts on problem with this oven. It is a Thermador Model# MED302JS/04 double oven electric. Unit has the needed 240v coming into the unit. There is no display at all and no functionality when any buttons are pressed. The oven light comes on when the door is open. There are 3 boards in the unit which are the Power Board / Relay Board/ and User interface. The Power board which is P/N# 00663802 has 3 wires One Black line (120v) / Neutral and Ground. Also there is one series plug that have a couple coming off of it and when measured it is around 9V DC. That 9V DC line goes to the Relay Board. Measuring the Voltage going to the display board is 9V DC. I will also note that the Power Board has a mild chatter coming from the transformer on this board. When unplugging the wire from the Power Board to the Relay Board this chatter stops. This leads me to believe that the Relay Board is the culprit. Any thoughts on what might be going on here!?? The Relay Board which I am referring to is P/N# 12022214
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,025
Location
Redmond, Oregon
Not many techs here work on Thermador, including myself.

So you'll need to be patient till a Thermador tech. does help you out here.:)

Jake
 

Naveed Syed

Premium Member
Joined
Aug 22, 2022
Messages
4
Location
Houston TX
Pls first check output voltage and signal voltage on Power supply board

The volts on Pin 1 and 2 should be 9.6 volts
The volts on Pin 4 and 5 should be 9.6 volts
The volt on Pin 2 and 3 volts should be 4.5 Volts
Please check same supply on control board input on X1 Jack connector ( might be some wire is broken or not )

From X2 jack of control board output voltage is going to interface board

check on interface board pin 1 & 3 9.6 volts
Pin 1 & 2 5 volts fluctuation in volts from 4.7 in every two second if voltage is stable there is issue in signal, wires or need to replace control board.

Thanks
Naveed TX
 
Last edited:
If you feel that you have benefited from this site, and would like to show your appreciation.
Top