• Please note, some of the links on our site are affiliate links (Learn More)

MEDB835DC4 Maytag dryer no heat

MMCDANIEL1971

Member
Joined
May 9, 2022
Messages
1
Location
Texas
Model Number
MEDB835DC4
Brand
Maytag
Age
1-5 years
Hello, I have a electric maytag bravos xl MCT dryer. Recently all functions worked but no heat,except for timed dry. 2 weeks ago the timed dry function stopped producing heag as well. I replaced the thermstat, thermal fuse, and heating element. Not the normal mode runs for 5 minutes and shuts off, still no heat, nor do any others still no heat. Any help would be appeciated
 

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
6,375
Location
Ontario, Canada
There doesn't appear to be many possibilities in the heater's wiring circuit.

heat circuit.png

Most of those you say you've already checked. Did you test each with at least one wire removed from the component before testing?


Has anyone confirmed the full 240 volts at the dryer outlet and at the dryer's main terminal block? That would usually be one of the very first things needing doing for a 'no heat' complaint.

LINK > The Appliance Clinic : Dryer Wall Outlet Power

LINK > The Appliance Clinic : Dryer Main Terminal Block

If the parts were tested properly and they tested Ok, that pretty much leaves the wiring, the electronic control and the heater circuit of the motor switch (which is pretty rare to fail besides a wire burning off).

Only the electronic control itself would be affected by changing to a timed setting so the control might be most likely to be responsible.

LINK > Maytag MEDB835DC4 Electronic Control

I do not know how it can be confirmed though. Maybe try to isolate the K2 'Heater Relay' on the board and see if power is flowing through it when the dryer should be heating?


Dan O.
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top