• Please note, some of the links on our site are affiliate links (Learn More)

MEDX655DW1 Maytag Bravos Electric Dryer not heating

Sooner89

Premium Member
Joined
Apr 1, 2020
Messages
3
Location
Houston
Model Number
MEDX655DW1
Brand
Maytag
Age
1-5 years
I have a maytag bravos dryer that was not heating. We replaced Cycling Thermostat and it worked fine for a couple of days. Now its not drying again. We have checked the thermostat, hi and low fuses, heating element and all are getting continuity. Even confirmed that the heating element is getting current when it is on but it is still not generating any heat. We have even taken the hose off and let it run to see if it will heat. Anyone have any other ideas on what the issue could be?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
Hi,

It could be a voltage issue, I've run into many dryers that will run and not heat OR NOT RUN AT ALL on my service calls. You may have a broken wire from one of the hot legs that connects to the terminal block in the back of the dryer.

Unplug your dryer, and pull it out from the wall and remove the metal cover where your power cord connects to your dryer and see if any of the wires have burned.

You would need to check for 220-240 volts at the terminal block with a multimeter.

Many times I've seen just 120 volts coming in, not 240 volts, thus your dryer motor will run, but not heat.

Put your multimeter leads on both ends of the terminal block, it should read 240 volts.

Remember Black & Red on the ends are HOT, White in the middle is NEUTRAL

Then put one of your meter leads in the middle of your terminal block and one on the end you should read 120 volts, then on the other end you should read 120 volts as well.

Look at this from another member that had this same issue:

(click to enlarge)
FriedWires.jpg

If you find that has a burnt hot wire like in the photo above, then you would need a new terminal block kit and new dryer cord.

Here's the terminal block kit for your model:
279320 Terminal Block Kit


Jake
 

Sooner89

Premium Member
Joined
Apr 1, 2020
Messages
3
Location
Houston
well we have verified this again and everything looks ok on that end. however we started it up and it ran with heat for about 20 minutes and then nothing again...now no heat at all.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
Its likely a electrical problem in your home breaker or wall outlet where it plugs into, because if it was a dryer problem it would not heat at all no matter what.

Jake
 

Sooner89

Premium Member
Joined
Apr 1, 2020
Messages
3
Location
Houston
The dryer runs but gets no heat or it has run for about twenty minutes and then no heat but continues to run.

That could be a problem with the outlet or the breaker? Just want to make sure i understand. Assume i can just test the breaker but the power to the outlet is 120 in each slot.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
118,957
Location
McMullen Valley, Arizona
Do this: Dry the next load on TIMED DRY and see if it still does the same thing or not.

Jake
 
Top