• Please note, some of the links on our site are affiliate links (Learn More)

FIXED NE597R0ABSR Samsung Electric Range, Pop and flash from back of stove

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
Model Number
NE597R0ABSR
Brand
Samsung
Age
1-5 years
Have a year and half old samsung electric range. Wife was using stove top burner and turned knob from the front big burner, through off, to the small back burner. When she did this she immediately heard a pop, and a flash from back of stove. No error codes on display, and oven seems to function fine except there is no warming to anything, even oven.

Model number is NE597R0ABSR

I am very mechanically inclined and will be bringing home my dvom this weekend from work ( diesel mechanic). Just need a little guidance on what to check. Ive already pulled the stove out and checked for anything obvious

Thanks


Cody
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,065
Location
McMullen Valley, Arizona

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
No burners seem to be working and the oven will not warm. I have not looked at any component real hard, just took a quick look at everything. I plan on taking time to test components saturday.
 

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
Thanks guys! Ill be bringing my meter home to do some testing tommorow morning. Wife said i need to get it fixed before thanksgiving lol, its at our house this year!
 

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
Morning update, no error codes when checking them
No heat from anything, fans come on, control panel acts like nothings wrong, nothing obviously burnt
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,065
Location
McMullen Valley, Arizona
Ok, did you check your home breaker box? All electric ranges have a dual breakers, if one is tripped it will light up the indicators and oven light bulb, but won't heat any of the heating elements.

Reset that dual breaker in your home breaker box, by turning them off then on again.

If still nothing, then turn the dual breaker off and pull the range out from the wall and check your terminal block where the power cord connects to and see if its burnt there.

Here's the terminal block for your model:
Samsung DG96-00173A Assy-Terminal Block - AppliancePartsPros.com


Jake
 

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
Lol

Was just getting ready to post this. At the terminal block i seemed to only be getting one leg of 220. So i went in basement and checked power out of breaker. I was gettin 250v and both legs were working fine. So i went back upstairs and checked it again after the terminal block and now i am getting proper voltage on both legs, and stove is now working. The right side of the terminal block seems to be loose. The wire connections are not loose but from the block itself, not much though. I did leave my meter hooked up while wiggling all connections and no change in voltage. Would it be wise to order a terminal block to be on the save side?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,065
Location
McMullen Valley, Arizona
The right side of the terminal block seems to be loose.
Can you tighten it? Turn the breaker off first! Or unplug the Range first!

If you can't tighten it, then yes order a new terminal block.

Jake
 

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
Ordering up a new one from the link you provided just to be safe. Ive got it all slid back in and buttoned up now. We will wait to use it until i can install the new block. Ive got the breaker shut off in basement for now.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,065
Location
McMullen Valley, Arizona
Ok, yes that's best just to be on the safe side.:)

Make sure when you get it and replace it that you tighten all the screws to it very tight, so the power cord terminal ends are very tight.

Jake
 

robins44

Premium Member
Joined
Nov 15, 2016
Messages
7
Location
Michigan
Thanksgiving went flawlessly, new terminal block is installed and stove is running great!

Thanks

Cody
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
109,065
Location
McMullen Valley, Arizona
Excellent Cody, glad to hear that.:)

Thanks for the update!

Jake
 
Top