Need help finding parts for 60s Hotpoint electric stove/oven

sgates248

Premium Member
Joined
Jan 19, 2014
Messages
2
Location
Ypsilanti, MI
Model Number
342143
Brand
Hotpoint
Age
More than 10 years
Hello. I'm hoping someone here can help. My wife and I purchased an old turquoise Hotpoint electric stove/oven recently. I'd like to get it working so we can use it (obviously). The oven works but only one burner comes on. The burner that does come on only works on high. I did some resistance testing of the switches with my DMM and I believe they've all gone bad. I would like to buy some but am having a hell of a time finding the correct ones.
The stove/oven is a Hotpoint model #342143. The schematic on the back is dated 1964. The switch has part #343024 stamped on it. I've done a ton of searching online and can't seem to find anything. Perhaps someone here knows a good place to look. I appreciate any advice/leads. Thanks!

-Shawn
 

sgates248

Premium Member
Joined
Jan 19, 2014
Messages
2
Location
Ypsilanti, MI
Not push button. They are dials. I will post a pic today or tomorrow. Sorry...it didn't occur to me to include one for some reason.
Yesterday, I did find that a wire to one of the elements was broken so fixed that and now it seems like 3 of the elements are working. I'm not sure if they are working in all settings (warm, low, med, etc.) but they were definitely working. The front-left was still out completely so I think I still need to at least replace that one.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,772
Location
Murray, Utah 84107, United States
OK sounds good. That old of a range might have three wires going to the elements. If it does you'll need to take a picture of the element ends/connections so I can show you how to connect a new switch. Take a picture of one of the knobs and back of the switch.
 
Top