Neptune 4000 series possible MCU problem

Eleua

Premium Member
Joined
Aug 27, 2007
Messages
2
Location
washington
Model Number
MAH4000AWW
Brand
Maytag
I have the MAH4000AWW series washer from Neptune Maytag.

Upon start, the pumps run for 43 seconds (no more, no less), and fill or drain as scheduled by the timer. After the 43 seconds, the unit shuts down. The motor does not run at all - zip.

I ran all the diagnostics that come with the wiring diagram. 10A fuse on the MCU was blown. I replaced it, and now the fuse has continuity, but the problems are the same.

I checked continuity with all three phases in the motor. All are showing direct short (not the 2-3 ohms as the diagram calls for).

My guess is the motor went Tango-Uniform and blew the fuse on the MCU.

Sears wants $500 to replace motor and MCU.

Home Despot is selling the 6700 series for $600 with a $50 rebate.

Obviously, I'm looking long and hard at the new 6700. Is it reliable?

It would appear that the 3000/4000 series had many problems with the MCU/motor (which is why there is a new part).

Comments on the 6700, and possible problem with my 4000.

Thanks,
E
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,334
Location
McMullen Valley, Arizona
Yes the Maytag 3000/4000 models had many issues, as they were basically the first generation front-loaders, the new 6700 models have all been doing really good, hardly any problems to speak of at all.

Jake
 

wondering

Premium Member
Joined
Nov 4, 2006
Messages
66
Location
ALABAMA
I also have the Neptune 4000. Only problem I have had was the door lock and board replaced under warranty a few years ago. You should check your warranty. The motor has a 10 year warranty on it and see what it would run you to get that replaced. If I were going with another Maytag I would consider the Neptune 6500. They are supposed to have all the bugs out now but the Epic seems nice too but it is a Whirlpool made machine but that isn't bad either.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,334
Location
McMullen Valley, Arizona
The Epic has been doing really good, haven't seen or heard of any problems yet.

Jake
 
Top