• Please note, some of the links on our site are affiliate links (Learn More)

NEW Whirlpool Dishwasher WDT750SAKZ Heating Element Not Working?

rstark18

Premium Member
Joined
Mar 10, 2016
Messages
13
Location
CA
Model Number
WDT750SAKZ
Brand
Whirlpool
Age
Less than 1 year
I have a brand new WDT750SAKZ and it seems as though the heating element is not working when using heated dry or extended dry.
At the end of the cycle or even hours later. the door, walls and racks are still very wet. I assume this is not normal. Or maybe the venting is not working?

I previously had a WDT750SAHZ and when the cycle ended the inside walls were completely dry. It did not have the vent in the front but I assume it had some sort of vent.

I think I will be returning this instead of having them come out and fix it and purchase the WDT970SAKZ.
Please post if you have any advice on this issue.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
They have issued a service bulletin on the heating element, but mainly its for a leak at the heating element bushing. But any slight leak may have caused the heating element to short out.

Here's the UPDATED heating element kit for your model:

But since its brand new under warranty contact Whirlpool at 1-866-698-2538 to come out to fix it for free.

Check to see if your serial number falls under this service bulletin:
 

Attachments

  • service-pointer-W11540964-revd_EN_SP_FR.pdf
    347.1 KB · Views: 77

rstark18

Premium Member
Joined
Mar 10, 2016
Messages
13
Location
CA
Thank you for that. My serial number falls outside of the defective units (FA2xxxxxx).
I did place a return on the unit and ordered the 970. Hopefully that will be a better unit for drying (but I’m not so sure). I’m somewhat limited on what units I can get as I want to do this through Costco.
If it weren’t for that I’d be getting a Bosch.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Ok, let us know how it goes.

Jake
 

UncleBryan

Member
Joined
May 29, 2022
Messages
1
Location
Michigan
I have the same model I have the same model as the op, with a similar problem. When mine came out of the box, I noticed two blue wires underneath that were detached along with what looked like ports for them to plug into. So I plugged them in. The ports look like they connect to the heating element, but it’s still not drying. My serial number also falls outside the range for the service bulletin. Any advice would be appreciated.
 

Attachments

  • 34599929-9ABB-45E7-9533-444C617B3E17.jpeg
    34599929-9ABB-45E7-9533-444C617B3E17.jpeg
    257.3 KB · Views: 47

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Its under warranty, so contact Whirlpool at 1-866-698-2538 and have a tech come out, the tech can call the factory on a special HOTLINE tech number from your house, and the factory can get involved in investigating what the problem could be.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top