• Please note, some of the links on our site are affiliate links (Learn More)

No lights/controls on Bosch SHP65T55UC/09 Dishwasher

anon

Premium Member
Joined
Oct 15, 2014
Messages
6
Location
California
Model Number
SHP65T55UC/09
Brand
Bosch
Age
1-5 years
I am having lots of trouble figuring out what is going wrong with my Bosch dishwasher. I do have power going to the dishwasher (I checked the end of the power cord that plugs directory into the dishwasher main board), but no lights/controls. I've tried replacing the main board and controls, but no luck. The power switch seems okay, there is continuity when it's pressed.

Is it possible the door sensor always thinks it is closed so it doesn't light up the controls (which are on the top of the door)?

Any help is greatly appreciated!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,325
Location
McMullen Valley, Arizona
Hi,

A few members have found that the terminal was the cause, look at post #10 through post #13 here:

Your model uses the exact same terminal:
Bosch 00628793 Terminal


Jake
 

anon

Premium Member
Joined
Oct 15, 2014
Messages
6
Location
California
Looks like I don’t have that terminal part. My power cord runs directly between the outlet and the main control board
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,325
Location
McMullen Valley, Arizona

anon

Premium Member
Joined
Oct 15, 2014
Messages
6
Location
California
It looks like there is an optional accessory without the junction box? I think what I have is option #2 from this document:

askboschbestbuy.com/wp-content/uploads/sites/2/2013/05/Power-Cord-Installation.pdf
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,325
Location
McMullen Valley, Arizona
Yes, now that makes sense.:)

You have checked for power and its there, you've replaced both control boards to no avail. So the only thing left is a broken or shorted wire to the control panel User Interface, I'd check that next.

Check all your wiring from the control board to the control panel User Interface for a short or broken wire.

If your wires are fine, then I don't know what else would cause this problem, but I rarely work on Bosch, so hopefully a tech. that works on Bosch day in and day out can shed some light on this.

Jake
 
Top