• Please note, some of the links on our site are affiliate links (Learn More)

Oven preheats, but then loses temp (GE electric oven model #: JK5000SF5SS)

rhalt

Member
Joined
Feb 14, 2021
Messages
1
Location
NH
Model Number
JK5000SF5SS
Brand
GE
Age
1-5 years
Having a problem with my GE electric oven (model #: JK5000SF5SS). It is a 27" wall mount with conventional and convection bake options. The oven pre-heats to the correct temperature, but then steadily loses heat. If we stop the bake and restart immediately, we'll note that the temp has dropped drastically. For example, if we set the temp to 350, it pre-heats to 350 fine. If we check the oven 15 minutes after finished pre-heating the temp is down to around 300. At this point we will restart the bake at 350 and the oven will reheat back up to 350 and the same cycle repeats itself. You can imagine how frustrating this is when you are trying to cook something for 30 minutes at 350! Further, since we have to restart the pre-heat cycle in the middle of a bake, the top broil element turns on during pre-heating and is burning the top of our bakes.

I have tried a number of the things with no success and would be keen to hear if anyone has suggestions. I've replaced the temp sensor and control board and have confirmed all the elements work independently. I thought this was going to be a control board fix, but no luck.

Any suggestions on this one?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
41,273
Location
Murray, Utah 84107, United States
Top