• Please note, some of the links on our site are affiliate links (Learn More)

FIXED PDF820SSJ0SS won't start, 3 beeps even with new door latch and control board

jym5

Premium Member
Joined
Nov 11, 2022
Messages
7
Location
Sacramento, California
Model Number
PDF820SSJ0SS
Brand
GE
Age
1-5 years
DW will not start, with 3 beeps.
I thought it was door latch first. Replaced with a new one. No difference. I measured the resistance between Pin 3 and 4, pin 3 and 5 on J711 from the back side. They're under 1 ohm when door is closed; Open when door is open.

So I thought it must be the control board. Ordered a new one and replaced it. Same thing, still got the 3 beeps, DW would not start.

Entered diagnostic mode, 10 seconds of flash light. No other indication. Control board LED is solid on. Can it be anything else other than door latch signal issue?

What else can I do? Hate to throw the whole thing out.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Do all the buttons work and respond on the UI Board at the top of the dishwasher door?

If so, then you have a faulty machine control board, contact the place where you got it and they should be able to send another new one.

Here's the machine control board for your model:

Look here:
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona

jym5

Premium Member
Joined
Nov 11, 2022
Messages
7
Location
Sacramento, California
Got another board today. Connected. Still the same symptoms. I guess it's not the control board.
I measured the impedance again between pin3/4 and 3/5 with door open and closed. They're still ok too. At a loss.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
It has to be the machine control board or a frayed broken wire at the control board. Did you check for any broken/loose wires?

--->Its best to contact GE at 1-800-432-2737 to have a GE tech. come out to see what's going on or go dishwasher shopping.
 

cninham

Premium Member
Joined
Jun 19, 2009
Messages
23
Location
Saint Augustine, FL
@jym5 -- I am having the exact same issue. Stumped and cannot identify the cause of the issue... Replaced my control board and door latch twice in two days...

See the description of my issue and troubleshooting here below. If you find the solution to the problem, please let me know!

 
Last edited:

jym5

Premium Member
Joined
Nov 11, 2022
Messages
7
Location
Sacramento, California
Thanks Cameron for the information.
Did you find something wrong with the UI board? Or control board is ok because 13.5V is there, so it's likely a problem of UI board?
So the diagnostic information (all LED flashing) about door latch is wrong?

Thanks.
 

cninham

Premium Member
Joined
Jun 19, 2009
Messages
23
Location
Saint Augustine, FL
Thanks Cameron for the information.
Did you find something wrong with the UI board? Or control board is ok because 13.5V is there, so it's likely a problem of UI board?
So the diagnostic information (all LED flashing) about door latch is wrong?

Thanks.
@jym5, from the outside the UI board appeared fine... The LCD display worked fine, the buttons worked (eg I would change the cycle and the time for the selected wash cycle in the display would change accordingly). Voltage at the the UI board was fine. Where I noticed the issue: when I dropped the control board (at bottom of dishwasher) the status LED would always show a steady green (indicating no communication between UI and control board) -- instead it should be blinking once a second when a cycle is selected and in standby mode but wash not yet started. Once I replaced the UI board, the control board LED would blink appropriately depending on which stage of the wash cycle it is in...
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
My status LED is steady on too. My UI board was replaced 3 months ago. I'll follow up with GE. Thanks.
Here's your service manual: https://drive.google.com/file/d/1vUUXq54uhVXGMWX7DylkrOWz_L7v-21P/view?usp=share_link

Look on Page 50 and do the voltage test to the UI Board. Here's the UI Board(located at the top of your dishwasher door) for your model: Configured Ui Board WD21X32005

Snapshot_2 (1).jpg


Take the voltage reading from the J722 connector on the back side of the control board.

That J722 connector is on the other side of the control board, look here:

J722.jpeg


It's the one on the left above the ethernet port.:)

Let us know what you find.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Ok, good, that means the UI Board is the culprit.

Here's the UI Board(located at the top of your dishwasher door) for your model: Configured Ui Board WD21X32005
 

jym5

Premium Member
Joined
Nov 11, 2022
Messages
7
Location
Sacramento, California
To close this thread out properly -

I got a replacement UI board WD21X32005 from GE 10 days ago (It was under 1 year warranty). I finally tested it today. First it didn't turn on at all. I double checked the personality jumper. I got it upside down. Fixed that. It lit up and no more beeps. It works! GE really needs to update their wrong diagnostic mode information.

But at this point, I'm not keeping this dishwasher. My family couldn't live without a dishwasher for long. We bought a new one a few days after this one quit. I didn't want to give this dishwasher to others as it is already more than 5 years old. Who knows what else will break. I guess I'll just sell the boards. Anyway I'd glad the issue is understood. Hopefully this is one more data point for others who run into similar problems.

Jake and Cameron - thank you for your help :).
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
Glad to hear the new UI Board fixed it.(y)

Thanks for the update!

But at this point, I'm not keeping this dishwasher. My family couldn't live without a dishwasher for long. We bought a new one a few days after this one quit. I didn't want to give this dishwasher to others as it is already more than 5 years old. Who knows what else will break. I guess I'll just sell the boards. Anyway I'd glad the issue is understood. Hopefully this is one more data point for others who run into similar problems.
I completely understand.
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top