• Please note, some of the links on our site are affiliate links (Learn More)

FIXED PFE29PSDASS Fridge Still Warm w/ New Evap Fan; Freezer fine

Gear Head

Premium Member
Joined
May 13, 2020
Messages
2
Location
Oregon
Model Number
PFE29PSDASS
Brand
GE
Age
6-10 years
Hey Guys,

I got a new (to me) PSD29PSDASS fridge and i go to plug it in and notice that the fridge portion isn't cooling at all, temp is 62deg F but the freezer seems to work fine, it overshoots temperature a little bit by reading -4 deg instead of 0 deg (setpoint).
1.) Investigated the fresh food (fridge) evaporator fan motor and it was seized so i ordered a new one. i checked for DC voltage with my DMM and i'm getting 13.8V across the red and black wires yet when i received my new evap fan motor it runs for very small amounts of time then stops completely. it is also running very slowly (i think). Right now it's still not cooling the fridge portion at all but the other thing i noticed was that the crisper bin tray has no temperature readout on the display but the LED"s work and you can switch the settings around. Could this be related as in a main control board issue??
2.) It seems there's also no air flow to the crisper bins either
3.) Does the damper fan have any play with this?

There's no error codes on the display, all the lights work, everything else seems in order and the freezer gets cold so i'm assuming it's not a sealed system issue yet. The compressor/condenser fan works.
i haven't tested any of the water or ice maker functions yet because it's not hooked up to water currently.

Any help would be great!!
thanks,
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,898
Location
McMullen Valley, Arizona
Hi,

It depends on the serial number of the refrigerator.

If the refrigerator was made between (May 2014 - Mar 2015) with the serial range HD - FF the software must be updated by factory service or a Software Update Module WR98R882802 for proper performance.

What's your serial number?

If your serial number is outside that range, then the new evaporator fan motor will fix it. What is the part number you ordered?

Here's that evaporator fan motor from RepairClinic for your model:
Evaporator Fan Motor WR60X26866


Jake
 

Gear Head

Premium Member
Joined
May 13, 2020
Messages
2
Location
Oregon
Hey Jake! thanks for your reply. Serial is MZ... 2012 model
Yes this is the fan i ordered and replaced. i originally thought it wasn't working because it was barely spinning right when i plugged it in and cycling on/off.
Well come to find out after a good bit of internet reading that the refrigerator attempts to cool down the freezer before the fresh food (refrigerator) section so until the freezer reaches about 12 degrees, there's no cooling on the refrigerator section as the three way valve for the refrigerant is turned to freezer only.
After learning this, i plugged it back in and let it sit for a couple of hours and it's cooling both compartments well now.

one more question though:
The produce/crisper temp display on the lower two drawers is not showing up, what could cause this?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,898
Location
McMullen Valley, Arizona
Excellent, glad that was all it was!

one more question though:
The produce/crisper temp display on the lower two drawers is not showing up, what could cause this?
Your tech data sheet should be located in the right side upper door hinge cover, trace back where it gets its power from and see how many volts your getting to it.

If your getting proper power to it and its not lighting up, then its bad too.

Here it is for your model:


Jake
 
Top