• Please note, some of the links on our site are affiliate links (Learn More)

FIXED RBD275PDQ6 Whirlpool Double Oven Display Blank Nothing Works

Fox

Premium Member
Joined
Jan 13, 2022
Messages
24
Location
Tennessee
Here is what I think likely occurred: There was one of those problems to begin with which caused the initial control to fail. The person that repair it the first time just replaced the part but didn't bother to find and correct the cause. The replacement control eventually suffered the same fate. This time they erroneously blamed using the self clean as the cause.
I agree that they probably didn't look for the cause. We haven't used the self clean mode since the last time Whirlpool came out and replaced the panel. (15+ years ago).

I do not know the temperature failure point of those relays (check with the relay manufacturer) but almost surly the thermal fuse would open well before those relays got hot enough to fail.

When the oven failed this time, there was no control panel thermal fuse to fail at p7-1; it was missing. That is how I found it from the previous time it was repaired (15+ years ago) as mentioned in previous posts back on January 15th.
 

Fox

Premium Member
Joined
Jan 13, 2022
Messages
24
Location
Tennessee
I have repaired/replaced the burnt P5 connector with these plastic connector housings (attached picture) I obtained from: https://www.te.com/usa-en/products/brands/positive-lock.html?source=header-match&tab=pgp-story

In addition to repairing the P5 connectors, I replaced all the thermal fuses including the missing one and reinstalled the rebuilt control panel. Circuit Board Medics did a great job rebuilding the control panel.

The oven is now working. One thing I did notice when I turned the oven back on to start pre-heating was that I could hear the fans come on. I recalled that prior to the oven failure, I wasn't hearing the fans like I thought I should. I am guessing that perhaps the P5 relays that were replaced must have something to do with the fans running. I had planned to replace the fans but the new fans that I ordered had the same resistance readings as the old ones.

Time will tell if there is anything else wrong that I was unable to find. Thanks for the help!!
Harry
 

Attachments

  • New P5 Connectors.JPG
    New P5 Connectors.JPG
    30.5 KB · Views: 42

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
5,274
Location
Ontario, Canada
Glad to hear it. Thanks for the followup..


Dan O.
 
Top