Roper Washer RTW4740YQ0 doesn't drain before final spin

siwel.luap

Member
Joined
Aug 17, 2019
Messages
1
Location
Gilmer, Tx
Model Number
RTW4740YQ0
Brand
Roper
Age
1-5 years
I have a Roper Washer Model# RTW4740YQ0, it runs through the first few cycles but stops basically at or just before the final spin cycle without draining, the lid lock will flash, I try to restart it and it goes back to the Fill cycle but doesn't do anything but hum. Tried to switch it to drain and spin and still a light sounding hum. I drained it and replaced the switch and tried again and had same result. Drained it again and replaced the Actuator and it ran with just water on the extra low water setting but on the second try on medium water with some towels it stopped at the final spin again without draining the water. The drain looks fine, the line was clear and it tested fine. I'm at a loss where to go from here.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
101,445
Location
McMullen Valley, Arizona
Hi, That hum sound is possibly coming from your drain pump.

I'd first check your drain pump for a clog, I see that happen 9 out of 10 times when it won't drain or won't drain properly, also when its humming feel the drain pump to see if that's where its going from.

Here's the drain pump for your model:
Drain Pump WPW10276397


There is a video on how to access it in the part link.

Have a lot of big old towels handy, that water in the tub will gush out when you remove the rubber hoses to the drain pump.

Jake
 
Top