FIXED Samsung Range/Oven NE595R0ABSR/AA LCD Broken numbers

field3d

Premium Member
Joined
Feb 1, 2019
Messages
4
Location
Texas
Model Number
NE595R0ABSR/A
Brand
Samsung
Age
1-5 years
Hello I have this Oven range NE595R0ABSR/AA.
We have broken numbers in this piece DE92-03045F. We bought the piece and a company sent us 4 pieces and all the 4 new ones are the screen black and you don’t hear clack sound at the beginning. Each time we place the old one with broken numbers you hear clack and the clock is on, of course with broken numbers, but immediately turns on. But the company, sent 4 pieces and all pieces are wrong dead without hear clack at the beginning is rare no? Or what could be the problem? If I buy in samsung again the piece DE92-03045F what will happen, the same, dead screen or is there something to do?

Or what is the piece that corresponds similar to DE92-03045F or any link to another place with the correct one? But is there something to do when you change it because 4 pieces with same kind of error, I don’t believe that, that 4 pieces dead screen and no clack sound when you plug to the wall the range. And the old one, broken numbers, but when you return to the range and when you plug to the wall the range immediately there is the clack sound and the clock comes alive with the broken numbers, but there it is on. Then what could be the problem? 4 defective pieces? Or is there something to do? Or what piece I buy? In samsung and the appliances stores according with serial number they conclude that the DE92-03045F, but maybe is needed to activate something? I can’ believe 4 pieces came with problem and when you place the old one from factory runs in a second very well.

Thank you
 

field3d

Premium Member
Joined
Feb 1, 2019
Messages
4
Location
Texas
Thank you for watch the post. Yes indeed that piece. But exactly that piece is what I bought and 4 times the company sent and the 4 times made nothing no clack sound when you give power to the range. That is why I ask if that could be other problem, because the strange is that the pcb with broken numbers (the one who came from factory) when you put immediately responds, with broken numbers and defects but turns on very well and 4 supposed new no respond to anything, unless they shipped only defective products because they shipped in plastic thin envelopes all times and matter that I said to the company.Do you think the 4 could be defective or could be other problem? Consider the factory PCB runs pretty well with its defects, of course.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
35,237
Location
Murray, Utah 84107, United States
OK, let me explain it this way; That is the only thing it can be. The reason they sent you four is they were probably warranty returns and they were hoping one would work. If you order a part from a link I give you and it doesn't fix the problem you can return it for a full refund less shipping.
 

field3d

Premium Member
Joined
Feb 1, 2019
Messages
4
Location
Texas
ok

Yes one piece came broken the others in very bad shipping and I said that to them. But the 4 came wrong? And yes that happened I had a refund, but then is that piece? Or exist the possibility that can be other thing?
 

field3d

Premium Member
Joined
Feb 1, 2019
Messages
4
Location
Texas
Worked

Hello. Just to confirm. I bought the piece and worked like a charm!

Thank you now the range/oven is working my wife is happy now!
 
Top