• Please note, some of the links on our site are affiliate links (Learn More)

Samsung Refrigerator RFG297AARS/XAA Compressor Inop, Fan running.

WazzuCoug

Member
Joined
Jan 7, 2021
Messages
1
Location
Minneapolis, MN
Model Number
RFG297AARSXAA
Brand
Samsung
Age
6-10 years
Good afternoon!
My Samsung refrigerator is not cooling and has the following symptoms:
- problem started 2 months ago when the frig went warm but then revived itself. Now it is not cooling at all.
- slow-blinking, red LED (= "Start Failure"),
- the compressor is inop (even in the manual service mode),
- the PCB Inverter board has evidence of being very hot (behind it the plastic enclosure is warped and discolored),
- and the opposing fan is running.

I have done the following troubleshooting:
- tested the wiring from the PCB board down to the compressor for continuity -- all good,
- looked over the main board and it appears normal,
- replaced the Overload Protector,
- checked all the big capacitors with a multimeter and they are good,
- tried to fire up the compressor directly with SUPCO 3-in-1 kit, but the compressor vibrates for 5 seconds then shuts down
- according to the stickers on the circuit boards, the model #'s are:
MAIN BRD: DA41-00538MP PCB-INV BRD: DA41-00614FP

So, now I am confused on the next step. I don't want to blindly throw expensive parts at it.
Could you please give me some guidance what to do (test) next?
As an all-around handy man, I am confident that I can fix the problem, once it is identified. I am ready to replace the compressor if necessary.
Thank you.
 

Attachments

  • SAMSUNG RFG297 MB_PCB-INV Model Numbers.jpg
    SAMSUNG RFG297 MB_PCB-INV Model Numbers.jpg
    53.3 KB · Views: 171

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon

SWall

Member
Joined
Nov 8, 2021
Messages
1
Location
Fort mcmurray
Hi jake,

I am having a similar problem with my Samsung RFG297AARS/XAC. I get the starting failure light blinking, then after 5 min the fan and the compressor kick in, but no cooling in the fridge/freezer and also no ice making. I took a brief look into that manual but require some assistance as to where to start. I was going to order a PCB sub inverter board but I am now not sure of that is the issue or not. Any assistance would be greatly appreciated

Sean
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,144
Location
Redmond, Oregon
Ok Sean, pull the refrigerator out from the wall, then remove the lower back access panel and see if the condenser fan motor(next to the compressor) is running.

Also put your hand on the top of the compressor and see if that's running and hot to the touch.

Jake
 

parlee

Premium Member
Joined
Nov 13, 2021
Messages
11
Location
Federal Way,WA
Hello Wazzu,
I hope you fixed the issue.

I am wondering if you can help me.
I have a same model as you have Samsung refrigerator. I disconnected the over load protector wires and i am not sure which wire go where.
Thought simple enough to remember but several days passed now I don't remember. Duh
I should have done marked it or took a picture but now unsure.
I think top of OLP brown wire and side would be blue wire.
Will you be able to check your over load protector near compressor and let me know?
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top