• Please note, some of the links on our site are affiliate links (Learn More)

Samsung RFG297AARS/XAA RevL-1 Fridge not cooling

simyson01

Premium Member
Joined
Apr 7, 2022
Messages
3
Location
WA
Model Number
RFG297AARS/XAA
Brand
Samsung
Age
More than 10 years
My Samsung RFG297AARS/XAA RevL-1 Fridge was freezing our food as the temp in the fridge was 20 degrees. I measured the resistance of the 3 sensors and all were within range, but went ahead and installed a new deli drawer and fridge sensor and the fridge stopped working completely. My freezer is spot on per the selected temp, but now the fridge compartment is doing nothing. I put the original sensors back in and still nothing. The damper appears to be functioning because it opens when the doors are closed and closes when they open. What should I try next? Any help is greatly appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
I helped another person with this similar issue here:
Do what I mentioned in post #2.

Jake
 

simyson01

Premium Member
Joined
Apr 7, 2022
Messages
3
Location
WA
Thanks Jake. I left the fridge for a few days and it has started cooling in the fridge again. It is set for 38 but the actual temp inside is 36 at the moment. I will watch and see if it will maintain a consistent temp. Should I still follow page 93 of the service manual or do you recommend something else.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
Should I still follow page 93 of the service manual or do you recommend something else.
No, not unless the compressor does not come on.
Look on Page 93 where it says: 4-2-18. If compressor does not operate There is a flowchart that will walk you through the testing procedure to do.

Jake
 

simyson01

Premium Member
Joined
Apr 7, 2022
Messages
3
Location
WA
So I have been watching the temps and they range anywhere from 30-40 degrees. Is that normal? It's not freezing my food and 40 isn't much higher than 38 so I guess this is doable but if it should be more consistent I would like to figure out how to get it functioning properly. Any advice is appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
Seems like the the control board is malfunctioning not doing what the sensor tells it to do per keeping a stable temp.

Here's the main control board for your model:
DA41-00538A Pba Main


Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top