• Please note, some of the links on our site are affiliate links (Learn More)

FIXED SHE3AR72UC/21 Bosch dishwasher refuses to drain - Error Code 25

Mac Brown

Premium Member
Joined
Mar 21, 2020
Messages
2
Location
Saint John, New Brunswick
Model Number
SHE3AR72UC/21
Brand
Bosch
Age
1-5 years
Trying to repair a dishwasher in a tenant's apartment. Dishwasher stops working with an error code E25 after every attempt to drain.
I have accessed the troubleshooting function of my dishwasher. The first thing that it does, is fill the basin with water, then it tries to drain.
The pump attempts to start 3 times, for 4-5 seconds each time. Then the E25 error code is thrown. This is what happens every time it attempts to drain.

The pump runs fine if I start it up without water turned on.
This is what we have tried so far:

1) Cleaned the filter, removed the filter top and checked for debris - none found
2) Removed the impeller cover and checked the impeller and area for debris - none found
3) Pulled the rubber back flow gasket and made sure it moved freely - check
4) Checked/cleaned the drain hose - no blockage found
5) Pulled the drain pump motor and checked to see if impeller freely rotates - definite pole step but moves freely
6) Checked for impeller damage - none found
7) Replaced the drain pump in case that was no longer functioning - no change
8) Pulled the drain line off of the sink drain, and attempted to drain into a bucket - still wont push any water though no static head
9) Pulled the pump, and tested the voltage during no load operation. Across the three phases, I have 45, 44 & 43 Volts.

The Pump I have is part# 00611332 which is rated for 3P AC 54V/55HZ.

Apart from replacing the control board, I feel as though I have tried everything.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
38,691
Location
Murray, Utah 84107, United States
Where did you get the motor? Remove power from the machine. Make sure the drain motor is at room temperature. Remove the three pin connector from the drain motor and on the motor measure the resistance across pins 1-2, 2-3, and 3-1.
 

matt.diyer

Premium Member
Joined
Mar 18, 2020
Messages
2
Location
North Carolina
Mac,

I just wrestled with this same issue myself. I searched far and wide on the web, looked through manuals, watched videos, search forums, and followed the same steps you did. After over 10 hours of frustrating troubleshooting attempts, I finally figured it out. The white plastic cover that sits in the sump was not seated fully! I finally figured this out when I had the drain pump removed and looked around with a flashlight. I could see that the white cover was not fully pushed down. I pulled it down while I was looking in there, and click! That was it! It wasn't making a good seal, so it was not allowing a proper flow for the drain pump. I should have taken a picture of good vs bad, but the following service bulletin shows this too, but from the top view:

I hope this works for you.

Matt
 

Mac Brown

Premium Member
Joined
Mar 21, 2020
Messages
2
Location
Saint John, New Brunswick
Matt,
I dont seem to have the blue locking tab thats shown in the service bulletin, so its possible that is what Im missing. Number 413 in the diagram.

1584982766249.png


I've attached a picture of what I currently have.
 

Attachments

Top