Thermostat won't stay set on GE unit

andy

Member
Joined
Jun 14, 2005
Messages
1
Location
, ,
imported post

This unit is just over one year old (thus the warranty is expired of course). When I set the temp at, say 70 degrees, within a couple minutes the unit automatically winds its way up to the top limit of 86 degrees! The compressor of course then turns off and the room gets hot.

At first it took some time, about 10-30 minutes before it would raise the temp. Now it's immediate. It won't even let me drop the temp below 86.

Anyone have any thoughts on this? I'm hardly willing to spend $100+ to get it fixed when I can buy a new one for $150-200.
 

aaastan

Appliance Tech
Joined
Mar 29, 2005
Messages
284
Location
Wilmington, Delaware, USA
imported post

Andy,

I am not familiar with GE window units(and I think all of the other moderators as well).

If the unit is out of warranty--and you have a small a/c around 6000btu--it usually is a better idea to buy a new unit. Personally I think the problem is with the electronic control(pc board). I am not an authorized GE warranty servicer---and thereforenot privy to GE service information.

Sorry.

John
 

psymon

Member
Joined
Aug 5, 2005
Messages
1
I have the exact problem as Andy with a 1 year old AC unit as well. Mine is a Maytag though but it does the same thing. you set the temp and through the next 10 minutes or so it will go up to like 88 degrees. I reset it back to 70 and within minutes it will start climbing again. VERY ANNOYING. specially when sleeping and you wake up because of the beeping and the room being very warm. ANY IDEAS??
 
Top