• Please note, some of the links on our site are affiliate links (Learn More)

VGIC365-4QBKM Viking Oven - two burners - both start fine - one shuts off

Kbhkgeorge

Member
Joined
Apr 25, 2021
Messages
1
Location
Oakland, CA
Model Number
VGIC365-4QBKM
Brand
Viking
Age
More than 10 years
I have An issue with my Viking oven. It was installed almost 20 years ago. Due to the stay at home protocols we have been cooking more. We noticed that the time it takes to warm up the oven is very long, 20 minutes plus. I took the oven apart and noticed that both burners had large holes close to the igniters. Also, one of the igniters did not turn on. After replacing both burners and the one ignite, things did not change much. I found that I could view the burners by opening the panel below the door. The sequence of events when the oven turns on are:
1) both igniters start glowing.
2) after a short time, 30 to 40 seconds, both burners lite with strong flames
3) after 15 to 20 seconds the left hand burner flames become very small and then stops

As far as I can tell, the left burner never comes back on.

In a previous thread:
The suggestion was that the igniters needed 3.2 or more amps or the gas would turn off. I tested the current and got 2.8. I then tested the current for the right side and got 2.8 also. I don’t know what to do next.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
44,177
Location
Murray, Utah 84107, United States
I tested the current and got 2.8.
Replace both igniters at the same time. Needs to be between 3.2 and 3.6 amps

viking-igniter-pb040001-ap5315579_01_l.jpg
 
Top