• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Viking Range VGSC305 Stove burners clicking issues

Status
Not open for further replies.

Vikinghelppleas

Premium Member
Joined
Jun 20, 2021
Messages
3
Location
WA
Model Number
VGSC305-4BDS6
Brand
Viking
Age
More than 10 years
Appreciate any help here! I have a VGSC305-4BDS6, which is probably at least 10 yrs old. Initially, the Stove burners would not click, but would light fine using matches, so I replaced the spark module. Old spark module was Harper-Wyman model 6540 and I replaced with a new PA020041 spark module.
After replacing the spark module, all the burners wouldn’t stop clicking. So, then I replaced all the old igniters with new PA020028 igniters. Where I’m stuck now is that the The Left Rear burner clicks, lights, stops clicking, but if heat is lowered to Med or lower, clicking starts up again. Left front burner won’t stop clicking unless left rear burner is turned on at the same time. Right rear burner will sometimes stop clicking after lighting, but not 100% of time, and will also start clicking if temp turned to Med or lower. Right front burner will stop clicking if right rear burner is on at the same time.

Thanks in advance for any suggestions to troubleshoot and hopefully fix this!
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,738
Location
Murray, Utah 84107, United States
You need at least one of these maybe more. The switch should show continuity or closed only when the knob is in the "Lite" position and open on all other positions.
viking-spark-switch-pa020015-ap3160646_01_l.jpg
 

Vikinghelppleas

Premium Member
Joined
Jun 20, 2021
Messages
3
Location
WA
Thank you very much for the info on the spark switch! I will buy one and try it out. I will post on whether this helps fix the problem once I get the part and install it.
In a new development, I had an appliance repair man tell me PA020041 spark module is not right for my range model/serial number, but I got that p/n info from the Viking parts catalog for my model, so I don’t know what is right. This PA020041 spark module that is now installed in my range has a current shown as 15 mA whereas the old spark module that I replaced was 8 mA. Could it be that the PA020041 Tytronics spark module has too high a current and is causing the continued clicking?
 
Last edited:

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,738
Location
Murray, Utah 84107, United States
I don't have an answer for you. Viking makes it impossible to get any service information and few places sell Viking parts.
 

Vikinghelppleas

Premium Member
Joined
Jun 20, 2021
Messages
3
Location
WA
Through some further troubleshooting, this problem is resolved. With new PA020028 igniters installed on each burner, since the new PA020041 spark module I installed was giving me clicking issues, I tried reinstalling the old Harper-wyman spark module, (which I had originally thought was causing the problem). Turns out there was never an issue with the spark module, just needed new igniters, and now everything is working great!
 
Status
Not open for further replies.
Top