• Please note, some of the links on our site are affiliate links (Learn More)

VIKING VGIC365-4QSS Burner Ignition Issues

kbleau

Premium Member
Joined
Feb 14, 2021
Messages
2
Location
Massachusetts
Model Number
VGIC365-4QSS
Brand
Viking
Age
More than 10 years
Hello! I would be grateful for any assistance.

I have a VIKING VGIC365-4QSS, serial number R06150113261. It was made in June, 2001. Most of the parts are original.

I'm having a problem with the RANGE (oven is fine). Over the last few months, the burners have gradually not been lighting well. Only 2 burners out of 5 are sparking regularly. I replaced both spark modules, the one that lights the left 2 burners, and the one that lights the right two burners and the grill.

At first, I thought I had fixed the problem because all burners lit fine the first time. However, I think it was just coincidence, because I'm still having the same issues.

I have cleaned all the burners and igniters. I have filed down the ceramic igniters to make sure there is bare metal. I have sprayed the connections with electrical spray and let everything dry.

As an experiment, I took the wire that is connected to a WORKING burner and connected it to a NON-WORKING burner. It did not work. So I am suspecting bad wires, connections, and/or igniters. It's a little funny that they all went bad in the course of a month or two though...

What should I try next? Thanks for any advice!
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
41,273
Location
Murray, Utah 84107, United States
In case you didn't know or if If you didn't already read this in another thread, Viking (and a few others) has made it impossible to get any service information, wiring diagrams, or tech sheets. It's hard to find most parts for their machines (unless you go through Viking).
Only 2 burners out of 5 are sparking regularly.
Which 3 are not working? It sounds like you're on the right track. If you switched the non working igniter with a working igniter and the igniter didn't work, the igniter is probably OK. Each surface valve has a switch that slides over the valve stem. When the valve is turned to the "light" position the contacts in the switch close. On the spark module, put one meter lead on "N" and leave it there. Touch the other meter lead to input side on the spark module for each igniter. They're probably marked on the spark module REIG-1, REIG-2 etc;etc. Turn the valve to the "light" position and your meter should indicate 120 VAC. No voltage ,check the valve switch.
 

kbleau

Premium Member
Joined
Feb 14, 2021
Messages
2
Location
Massachusetts
Hello! Thank you for reading my post.

I have a VIKING VGIC365-4Qss range/oven, serial number R06150113261. It was made in June, 2001. One of the two oven burners is not igniting.


I suspect there is a problem with the igniter or the gas tube or both. However, I should mention that I have recently been cleaning and repairing the RANGE, so I guess it is possible that somewhere along the way, a wire got nudged. I feel like this is unlikely because the wires to the oven igniters seem to come from a different place than the wires for the range.
Faulty2.JPG

Faulty4.JPG


FULL INFORMATION:
In 2018, the oven started taking a long time to heat up. A Viking tech person came and explained that the RIGHT burner was NOT LIGHTING. He replaced the RIGHT ignitor and the gas tube. It cost us a lot of money. I think he used a genuine VIKING part.

In March 2020, the same issue started happening at the LEFT BURNER. It started not lighting. I'm handy, so I replaced the left igniter and gas tube myself. It cost us very little money. The oven worked perfectly for a year. I think we used a knock off part. (see image below comparing the two parts. The VIKING part seems to have a coil. The knock off doesn't have it. It has something else.)

I'm wondering if the knock off igniter really could have failed in only 1 year (of admittedly heavy use).
Bad and Good Igniters.png

Any help would be appreciated.

Thanks! Kevin
 
Last edited:
Top