FIXED WDP350PAAW3 power up, lights on, but not filling or draining

Twytch

Premium Member
Joined
Sep 21, 2017
Messages
2
Location
MN
Model Number
WDP350PAAW3
Brand
Whirlpool
Age
1-5 years
Hi, I have a Whirlpool WDP350PAAW3 portable dishwasher about 2 years old. It powers on and lights up and control panel buttons seem to work fine, but will not fill and start the wash or if I hit cancel will not drain. I have checked door switch, float switch and inlet valve with multimeter and all came back okay. Inlet valve read 1400 ohms, clean screen and all three items had continuity.

After hand filling basin with about a gallon of water, I do the 123123123 diagnostic mode and after about 5 min it will do a wash mode and a drain mode that seems to work fine, but no fill mode at start and only grrs and noise if I don't manually fill basin with water at start. After about 20 min of diag mode all lights go off and heating element is hot.

Am I in some kind of demo mode or is my $100 control panel shot and not sending the go to inlet valve to fill? Tested to see if 120v going to inlet valve after hitting start and no juice seems to make it there.

Many days of testing and now down to hand washing dishes..ugg..please help

Thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,642
Location
McMullen Valley, Arizona
Yes,

If your not getting 120 volts to the water inlet valve and your float is DOWN and the float switch is good, then your control board is the culprit.

Here's the control board for your model you can order:
Control Board W10804120


Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,642
Location
McMullen Valley, Arizona
Excellent, glad to hear that.:)

Thanks for the update!

Jake
 
Top