• Please note, some of the links on our site are affiliate links (Learn More)
  • Important Announcement

    It's with sad news to announce that our site owner, Jake, has passed away. You can read the details here.

FIXED WDT720PADM2 Whirlpool Dishwasher Driving us nuts - won’t spray (most of the time)


Jan 1, 2023
Model Number
6-10 years
I’ve read the other threads and watched videos on YouTube, but I’m still stuck. We have a six year old WDT720PADM2 that has been NOTHING but problems for the past six months.

Initially, wash cycle wasn’t running well. Food stuck on plates, and soap not dissolved. After chasing my tail (and diagnostic codes), here is what I found:

1. If left to it’s own devices, the water fills and drains. Heat works fine. Spray pump doesn’t work.
2. Service mode returns codes, of which there’s been many. I replaced the OWI sensor and the control board, based on the service manual. We always run the hot water at the kitchen sink before starting. No improvement.
3. The service mode gets the spraying to work well. Like new, actually. Running this mode usually gets the spray pump working again for the next 1-2 cycles.
4. No blockages anywhere…strainer, drain, spray arms. I haven’t taken anything apart beyond what I mentioned on account of service mode getting the spraying to work.

So I’ve read a lot about these pumps dying, but for the life of me, I don’t understand how a bad pump with a worn bushing will work consistently during the service mode and then for another 1-2 wash cycles. Seems like that should just never work. I figured this was caused by a bad controller, and that was supported by a code that seemed to verify the fault. But again, the new computer didn’t change a thing.

Any help is much appreciated! I’d hate to throw this in the landfill, but that’s the next stop if I can’t figure this out!

Death to the WDT720PADM2!​

It's usually the wash motor, this has become a common problem as of late, many members here have reported the same. In fact I had 2 in Sept. 2018 in Parker, Arizona that did the exact same thing, and the new wash motor fixed them both.:)

I'd first check to see if your getting 120 volts to the wash motor when it should be in the wash cycle.

Take the wire connector off the wash motor and use your multimeter to see if yours is getting 120 volts when it should be washing, if so and it's not running order the wash motor below.
(click to enlarge)

Here's the wash motor for your model:
Pump and Motor Assembly W11032770

Here's the video:
Jake - I need your wisdom! I have same model and doesn’t spray water. Just replaced wash motor and nothing has changed :(

What should I do next? Thank you!
I'd first check to see if your getting 120 volts to the wash motor when it should be in the wash cycle.

Take the wire connector off the wash motor and use your multimeter to see if yours is getting 120 volts when it should be washing, if so and it's not running order the wash motor below.
(click to enlarge)
Did you check for 120 volts at the wash motor electrical terminals, when it should be washing?
Then did you check it again with the new wash motor installed?

If you still get 120 volts, then your wash motor you got is defective, where did u get it at?
Ok, contact them and let them know, and they will send you another new one.
Jake - got the new motor. Installed it. Ran diagnostics mode to recalibrate everything. Ran 1hr was cycle and still not water flowing into spray bars/arms.

I did notice “bubbles” were making it into the top/lower spray bar but still not as expected.

What else could be wrong? A clog in a hose? Another part? I feel like its unlikely to be the motor at this point.


  • C404274F-5A4A-432C-97C8-86D3558BCDD5.jpeg
    400.9 KB · Views: 31
  • 74B7F38A-E792-4420-BE18-F7106788FD58.jpeg
    364.8 KB · Views: 29
Too many suds, run a cycle without anything in the tub and don't add detergent.

After it fills take a photo of how high the water level comes up in the tub.
So just ran a cycle, but the suds/old detergent that were there still weren’t going away. So i poured a few glasses of water into the tub. Hit resume and closed the door and it started working like normal! So what does that mean? Why is tub not filing up “naturally” when cycle runs?

5min later after it was “working like normal” Cycle is still running. Appears to have drained the water i manually added and now back to same behavior of water not getting into spray arms.
Turn the water supply off to the dishwasher underneath your sink, then take off the water line that connects to your water inlet valve and see if your screen is clogged up, thus not letting enough water come in the dishwasher.

Here's the water inlet valve for your model:
Water Inlet Valve W11175771

There is a video in that part link that shows you how to access the water inlet valve, see the water inlet valve screen in the photo above?
I did a basic visual inspection of the screen for debris and it looks clean/no mineral deposits or other debris . Should I do a more in-depth inspection?
Should I do a more in-depth inspection?

I just need to see a video or photo of how high the water level comes up after it fills.
Here is a photo leaving on spring break. Can get a video if needed next week. Basin/tub doesn’t fill up much.


  • 890AE35F-76F2-4DF5-9DC1-46CBD21EBB20.jpeg
    365.5 KB · Views: 38
Yes, I barely see any water in the tub.

But was that photo taken right after it filled when you first started the dishwasher?
Ok, At the very beginning when you first start the dishwasher, right after you hear it stop filling with water open the door and see how high the water lever is in the tub.

If the water level is good, then check for water siphoning out of unit:
1. Allow dishwasher to complete normal fill.
2. Drain for 5 - 10 seconds by pressing CANCEL/DRAIN.
3. Open door and confirm water does not siphon out of unit. If it does, confirm drain loop is attached to side of dishwasher and drain hose is connected to a drain at least 20" (50.8 cm) off the floor.

---->Make sure your dishwasher drain hose has a high loop in it before it connects to the garbage disposal or sink plumbing.

You can see how it has to loop in Fig 1, Fig 1a, Fig 2 here:

Basically no water in the tub. Here is pic of drain loop and you can see where hose is connected to drain in basement plumbing.

with little water going into tub I decided to check how much water was coming into dishwasher by opening the valve I installed once I had to start troubleshooting the dishwasher. Based on this video is seems like very little water is getting through the hose and into the dishwasher. Could this be an issue? If so i wonder if there is some Teflon or blockage from when I added the on/off valve (previously there was not one and I had to turn off water to entire house to troubleshoot). Should I disassemble the new valve and fitting to inspect for blockage? Is the fitting correct size for a dishwasher?

The issue I’m experiencing existed prior to me changing/adding the on/off valve so maybe something else is going on with the plumbing coming into dishwasher? Wondering this based on me manually filling the tub it appears everything works fine.
here is a pic of the plumbing to dishwasher prior to on/off valve installation


  • CC74F56C-48C4-436A-8A28-4C35271B18AB.jpeg
    261.9 KB · Views: 21

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.