• Please note, some of the links on our site are affiliate links (Learn More)
  • Important Announcement

    It's with sad news to announce that our site owner, Jake, has passed away. You can read the details here.

FIXED WDT750SAHZ0 Whirlpool dishwasher fills but won’t spray


Premium Member
Apr 29, 2023
Model Number
1-5 years
Alright I ran through the forums and having similar issues. The dishwasher fills but won’t spray. I pulled circ pump cleaned it and tested it on the bench. With a 120v it runs no issues. Put it back in the unit and it won’t run. I tested pump feed and during a cycle it sits at 54v and with jump to 114v and back to 54v. Is it pump or is it control board? I’m not a fan of just throwing parts at something especially when each of these is $300 a piece. Any input?
Hi, disconnect power to the dishwasher and ohm test the wash motor, normal would be 5-15 Ohms.

Here it is for your model: W11084656 Dishwasher Circulation Pump

Here's another member with this similar issue:
His KitchenAid and your Whirlpool use the exact same Circulation wash motor pump.
Ok, good.

When the wash motor is getting 115 to 120 volts to it, it should be running, if not its bad.

Here's how I do it in this thread, and advise others to do it the same way:
Excellent, glad to hear the new wash motor fixed it.(y)

Thanks for the update!

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.