• Please note, some of the links on our site are affiliate links (Learn More)

WFE540H0ES Not maintaining constant temperature

dtap98

Premium Member
Joined
Dec 21, 2019
Messages
2
Location
fl
Model Number
WFE540H0ES
Brand
Whirlpool
Age
1-5 years
Trying to bake cookies and oven is not maintaining constant temperature. Oven will reach 350 degrees but will take 1hr for cookies to bake, should not be more than 20 minutes. I am able to place hand in oven and feel very cooling temperatures. Will shut oven off, then set to 350 again, hit bake and wait for oven to heat up again. Did this until cookies finished baking. What is wrong and how do I fix this?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Let's first check your bake element, pull your range out from the wall, then unplug your range from the wall outlet, then watch this video to access it:

Check the back two bake element terminals to make sure it didn't short out there, if so order and replace it.

Then remove the cover from over the bake element per the video and see if your bake element has a hole in it, or any bad spots in it. If so, order and replace it.

If neither is the case, then you will need to ohm test it:

Here's the bake element for your model you can order if needed:
W10779716 Bake Element


Let us know what you find.

Jake
 

dtap98

Premium Member
Joined
Dec 21, 2019
Messages
2
Location
fl
Thanks for your help Jake. We followed your instructions and the element was fried!!! New element ordered and on it's way. Thanks again!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,199
Location
McMullen Valley, Arizona
Excellent, glad to hear you found it was the bake element. Let us know how it goes after you replace it.

Jake
 
Top