• Please note, some of the links on our site are affiliate links (Learn More)

FIXED WFG515S0ES0 Whirlpool Range - Gas oven won't light. Igniter is sparking and I smell gas.

Status
Not open for further replies.

Daireus

Premium Member
Joined
Dec 29, 2020
Messages
3
Location
Carlsbad CA
Model Number
WFG515S0ES0
Brand
Whirlpool
Age
1-5 years
Hi all. I have a five year old Whirlpool freestanding gas oven/range. About two years ago it started having intermittent igniting issues in the oven only. Broiler and range worked just fine. Eventually it wouldn't light at all. I replaced the igniter and all was fine until last week. Again the oven will not light at all. Broiler and range work fine as before. I can smell gas and I can see the spark from the igniter when I take off the bottom pan of the oven.
Any ideas what is going on or how I can fix?

Thank you in advance!

PXL_20201229_170222583.jpg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,160
Location
McMullen Valley, Arizona
How long ago did you replace the BAKE spark ignitor? Where did you buy it at?

Unplug the range first! Then Remove the bake burner assembly and where the igniter sparks you'll see small port holes. Take a wire brush and clean the burner assembly. Be sure to get the small port holes next to the igniter.

Also check the rest of the small port holes on the oven bake burner assembly, lots of the small port holes may be partially clogged/gunked up.

Here's the bake burner assembly for your model:
WP9758078 Burnr-Oven


Here's the bake spark igniter for your model:
WP9758079 Oven Igniter


Jake
 

Daireus

Premium Member
Joined
Dec 29, 2020
Messages
3
Location
Carlsbad CA
Thanks Jake. I'll give that all a try. I also just went ahead and ordered a new igniter. They are cheap and I need to get this thing back in working order quickly!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,160
Location
McMullen Valley, Arizona

Daireus

Premium Member
Joined
Dec 29, 2020
Messages
3
Location
Carlsbad CA
Thanks will do. I'll grab one as my backup. I got one of amazon just to get it quick and up and running. When this one fails I'll swap out the OEM. Up and running for now. I appreciate your help. Happy New Year!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,160
Location
McMullen Valley, Arizona
Ok, sounds good.(y)

Happy New Year!

Jake
 
Status
Not open for further replies.
Top