• Please note, some of the links on our site are affiliate links (Learn More)

WFG540H0ES0 Whirlpool oven not lighting

lchico

Premium Member
Joined
Dec 23, 2019
Messages
4
Location
Carol Stream
Model Number
WFG540H0ES0
Brand
Whirlpool
Age
1-5 years
I called for repair due to oven igniting but not lighting which is intermittent.Repair guy came out and said i need spark control board and oven harness. He said there is a service flash for these models not maintaining the temp. I am considering buying the parts. Anyone hear of this?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,299
Location
McMullen Valley, Arizona
I did locate the service bulletin for this problem, but your model number is NOT listed on it, only this one is WFG540H0AS0.

Does the broil igniter light? If that one does not light either then its likely a bad gas valve.

Check between each solenoid for 216Ω resistance. (Measure between the two Broil valve terminals marked B and between the two Bake valve terminals marked C.)
NOTE: Always check both solenoids. If one of the solenoids is defective, neither one will work.

2019-12-23.png


Here it is for your model:
Oven Valve and Pressure Regulator W10919226


Jake
 
Last edited:

lchico

Premium Member
Joined
Dec 23, 2019
Messages
4
Location
Carol Stream
The broiler lights up fine every time and burners are fine. I don't know if it is a coincidence but i'll turn on the broiler and then i hear the normal clicking when i turn on the oven and the gas ignites.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,299
Location
McMullen Valley, Arizona
I don't know if it is a coincidence but i'll turn on the broiler and then i hear the normal clicking when i turn on the oven and the gas ignites.
I don't understand that, so when you turn on the broil the ignitor clicks at the bake burner too and it lights the bake burner as well?

Maybe I'm misunderstanding?

Jake
 

lchico

Premium Member
Joined
Dec 23, 2019
Messages
4
Location
Carol Stream
Sorry if i explained it odd. Broiler works fine. Oven will click and no flames, on occassion. Guy came out and it happened to him. My repairman was on the phone with another repairman. He tested something and then he said i needed wiring harness and spark control module and 400 dollars for repairs. I have waited a week and thinking about ordering those parts. Would like 2nd opinion.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,299
Location
McMullen Valley, Arizona
Sounds like your oven burner port holes are partially clogged/gunked up. That will also cause this issue, I'd check that first.

Take a wire brush and clean the burner assembly port holes. Be sure to get the port holes next to the igniter. Unplug your range from the wall outlet first.

Watch this video below, it gives you the general idea of how to access it:

Jake
 

lchico

Premium Member
Joined
Dec 23, 2019
Messages
4
Location
Carol Stream
Thank you I will try. If that does not work, do you agree with his suggestion of spark control panel. I dont understand what a wire harness does.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
106,299
Location
McMullen Valley, Arizona
I'm attaching your tech. data sheet below, get into diagnostics mode on page 2 and go to step 6 and 6a to see if you have a error code and if so tell me what error code it says.

Jake
 

Attachments

Top