• Please note, some of the links on our site are affiliate links (Learn More)

WFW9620HBK0 Whirlpool washer not starting cycles

doolie

Premium Member
Joined
Aug 5, 2022
Messages
6
Location
Colorado
Model Number
WFW9620HBK0
Brand
Whirlpool
Age
1-5 years
Howdy. I have a fancy newish Whirlpool front load washer with a touchscreen in the door panel that won't start cycles. What generally happens after pressing start is a faint click from the control board, followed by nothing for several minutes. The door does not lock, though the machine does pause the cycle if you open the door. Sometimes the drain pump runs for a bit. Eventually, I get error code F6E3, which seems to be for lost connection between ACU (control board) and HMI (user interface).

Through much hassle, I was able to confirm voltage into the ACU, and also measured 12.86VDC at the connector for the HMI. This voltage occasionally dropped to about 9 when the LED on the board flashed. I also entered the diagnostic mode to run some component tests. Some tests work as expected. Others are... strange. Attempting a low speed spin will cause the door to lock, and after maybe 30 seconds, the drain pump will run. The basket does not spin at all.

Something else I've noticed is that after plugging the machine in, there is an hourglass on the screen for about 10-15 seconds followed by the Whirlpool logo, followed by a chime and the machine enters sleep mode. During this time, the screen often appears to flicker, freeze, or have a vertical black bar through it.

My suspicion right now is that the HMI is sending incorrect signals to the control, but I'm not really sure. I ran out of time to investigate. I want to be prepared the next I can get into it.

Any help is greatly appreciated.

Thank you,
Scott
 

doolie

Premium Member
Joined
Aug 5, 2022
Messages
6
Location
Colorado
Does anyone out there have any experience with these things or with getting Whirlpool to fix or replace things out of warranty? That HMI retails for close to $700 and quite frankly that is unreasonable to pay on a <2 year old machine.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,699
Location
Vicksburg Junction, Arizona
I located a service bulletin about this issue, I'm attaching it below.

Here's the HMI door assembly for your model: W11408902

Here's the ACU for your model: W11352117

You can contact the Whirlpool Corporate office and see if they will do something: http://www.whirlpoolcorp.com/contact/

North America Customer Experience Phone: 1-866-698-2538

Corporate Headquarters
Administrative Center
2000 North M-63
Benton Harbor, Michigan 49022

Jake
 

Attachments

  • service-pointer-w11375982-acu-diagnostic-led-correction.pdf
    1.5 MB · Views: 37
If you feel that you have benefited from this site, and would like to show your appreciation.
Top