• Please note, some of the links on our site are affiliate links (Learn More)

WGE555S0BS01 Whirlpool range/double oven heating problems

mjschmid

Premium Member
Joined
Feb 19, 2019
Messages
20
Location
Nebraska
Model Number
WGE555S0BS01
Brand
Whirlpool
Age
6-10 years
Have an electric whirlpool stainless steel range/double oven - normal size oven on bottom and small oven on top - about 7 years old.

It isn’t heating correctly. When preheating it will get within 10-15 degrees of final temperature and then just stay there and say preheating indefinitely. Heating elements appear to turn off. If I turn off the oven and turn it back on to preheat it is about 10 degrees lower than the previous shown temperature.

However, this problem is intermittent - sometimes it will preheat fully, but then while using the temperature swing seems to be too big before heating element will turn back on.

For example if set at 400 it will get down to 360 before turning heating element back on…
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
136,041
Location
Vicksburg Junction, Arizona
You can Ohm Test your oven sensor first with a multimeter. Make the breaker to your oven is off first, you have to pull the oven out from the wall and remove the back access panel to get to the oven sensor connector, OR or you can remove it from inside the oven. Remove the two screws and pull the wire connector through the hole then disconnect it.

At room temperature the oven sensor should be between 1050 and 1100 ohms.

Here's the oven sensor for your model you can order if needed:
WP7430P044-60 Sensor, Oven



Let us know what you find.

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top