• Please note, some of the links on our site are affiliate links (Learn More)

FIXED WHD560CHW2 Whirlpool Ventless dryer F9E2


Premium Member
Apr 27, 2022
Washington State
Model Number
Less than 1 year
Hi everyone, first post here. I'll try to keep it on point for you :)

I purchased Whirpool model WHD560CHW2, a ventless dryer, about 6 months ago. The installation crew did not install the power cord correctly, crossing 2 of the wires in the terminal. The first few times I tried using it, it made a loud noise, shook violently and immediately turned off. Once I popped the cover off of where the power wires were screwed in (the center wire was screwed into the right terminal, and right wire in the center terminal), I saw the mistake and corrected it, and the dryer functioned normally for 3 months.

After 3 months of use, we'd randomly get "F9 E2" showing up any time during the cycle - sometimes after 2 minutes, sometimes after 70 minutes. Service technician came out, fiddled with it for a bit and diagnosed a failed dryer user interface, part w11331944. He seemed 100% certain this was the issue. After a few weeks of intermittently working decently, it now always fails after about 2 minutes of running, regardless of if I'm doing an auto-sensing cycle or timed cycle. This part was on backorder and has been for the entirety of the past 3 months. I raised a big stink with whirlpool after being jerked around with no help for 3 months and no end in sight, and they ended up authorizing a replacement, but the dryer is backordered now and Home Depot instead gave me a full refund to purchase one "someday". I figured in the meantime I'd see if I could get this thing up and running.

I was able to find a replacement control panel and received and installed it today. The part is w11331944. Unfortunately, the dryer is doing the exact same thing with the new part, run for about 2 minutes then give F9E2. Below I'll list my observations and questions to see if you can guide me in what I may want to check/replace next.

- I suspect the underlying problem was a jolt of electricity that damaged something when the dryer was initially installed incorrectly - if you think I should cut my losses let me know. As far as I've looked (not very thorough teardown yet) I don't see anything scorched or wires melted.
- In googling this error code, it seems like it could be the thermistor? Would that be a good place to check next? In the 2 minutes it runs, it does seem to heat up appropriately and I don't find many instances of dryers shutting off promptly after starting due to a bad thermistor
- One of the 1-star reviews on whirlpool's website says they had this error code and their tech diagnosed failing heater coils - does this seem plausible? I kind of doubt it
- I put a dry towel in and the dryer was able to successfully turn on, run for a couple minutes (heat up, sense the towel was dry, then make it through the cooling cycle), and turn off normally so maybe it's something with the moisture sensor?
- could it be a water pump issue?
- When the dryer is running, it seems normal - no weird buzzing, vibrations, and the drum spins readily.
- probably unrelated, but the error code started about 2 weeks after one of the dryer lint screen doors broke (side note, these are designed terribly!)

Please let me know what your best guesses are and I'll start trying to work down the list.
small update as I've continued tinkering tonight...

Googling suggests many of the whirlpool washing machines throw F9 E2 code when there is "poor communication between the main control board and the water pump". Since this dryer condenses the water and pumps it down the drain when the reservoir fills, I also wonder if that could be the issue. I blew on the copper tube attached to the dryer, that has been sitting in my drain and it got the dryer working for significantly longer than I've come accustomed to (probably 5-10 minutes of function instead of 2 minutes). I'm wondering if there's either electrical damage to the pump, OR maybe there's a clog of dog hair making it impossible for the pump to drain.

This may be tricky to fix, as it's not something that any (?) other dryers have and I'm not particularly handy when I can't watch a youtube video first xD.
Yes, Here's your tech. data sheet: https://drive.google.com/file/d/1rCbyGwHn9Wl8s5cXVNOUOA5O2dDXTGnP/view?usp=sharing

F9E2 Drain Assembly Failure Indicates that the float switch is in full position and the Pump has been ON for more than 60 seconds.
See Test #9: Drain System, page 20.

Here's the service manual that shows you how to get access to the pump: https://drive.google.com/file/d/1OP5F07M49UyzivFS8ChF6jioRP8Z8qD4/view?usp=sharing

Yes check for pet hair or any kind of lint clog.

Page 4-13 shows you how to access the it--->Removing the Drain Pump & Float Assembly

Make sure you unplug the dryer before you do any work on it!

Let us know what you find.

Thank you for the links, wish it was easier to find that via Google! It seems the technician that came out initially blew it on the diagnosis then. This sounds like something he could have fixed months ago with little trouble. I guess I have a spare user control interface now, as I can't return it..

I took the back panel off last night and the water reservoir seems full. It makes sense with the timing of the error that this is the issue. When I blow on the tubing, a bit of water leaks out from where the hose clamp lies. It doesn't look too hard to access so hopefully will be easy to fix.

My plan is to take it apart, clean it (though everything is super clean since it's basically new), empty the reservoir and see what happens.

If the same error kicks out after I empty the tank, would it be reasonable to suspect the main control panel?
Sounds like your making progress.:)

If the same error kicks out after I empty the tank, would it be reasonable to suspect the main control panel?
That I don't know, I've not worked on this model as of yet.

Page 3 of the tech data sheet I posted the link to above tells you how to clear the error code, I'd do that after you fix it and hopefully that error code won't come back.

Let us know how it goes.

Let us know how it goes.

Just put Humpty Dumpty back together again. For anyone that stumbles upon this thread (F9E2 seems common for this model!) It was extremely easy to remove the water drain pump.

1) pull the back panel off (most time consuming, but very easy. Have a 1/4" nut driver handy),
2) unclip 2 electrical connector/brackets, 1 that goes to the float valve and 1 that goes to the actual pump,
3) remove 2 x 1/4" nuts, 1 from a metal bracket that holds the plastic threading that you screw your drain hose to (gives better access) and 1 from the back (closest) aspect of the drain pump
4) lift up and out. You've successfully removed the drain pump!
5) When you're done, it's a little harder to get it seated back in, as it's hard to tell if the farthest away part of the drain pump is seated correctly, but not bad. I'll be on the lookout for leaking during the next few loads to make sure it's on good.

The water pump reservoir was full to the brim, and there was a surprising amount of nasty slimy/muddy/linty debris at the bottom of the reservoir. I'm nearly certain the full tank is what was causing my error, now the question is why did it fill up and not drain?

The pump itself seemed clean and I didn't appreciate any obstructions. I blew through the tubing aggressively and a small amount of clean water came out, but absolutely no lint, hair, or aforementioned sludge. I took the little cap off (had 4 little clips that were hard to get off the body of the housing) and everything looked basically normal. Really the only thing I noticed is that I'm not sure whoever put the tubing and hose clamp onto the pump at the warehouse got it entirely air-tight (I blew on it earlier in the week, there was some water that leaked out where the hose attaches to the pump) - maybe this is causing the pump to pull in air instead of water.

The float valve moved freely and had a small amount of slimy buildup that I wiped off.

Based on my unremarkable exam, I suspect the pump or control panel is just plain broken. I tried to check resistance with my multimeter, though I don't really know how to use it (haha). I got a resistance of 0.9 ohms from the float assembly bracket. The probes on my machine were too big to reach the wires in the bracket that went to the actual pump.

I've got a load of laundry in the wash and will see how the dryer handles it with an empty reservoir. For now we'll see if cleaning everything out nicely and resetting the error code gets me up and running normally. I suspect I'll get a few normal loads of laundry, but whether the tank fills up again and triggers the same error code is the ~$100-300 question.

I have the dryer water outlet hose set to empty into a 1 gallon bucket to see if the dryer is able to pump any water or not. If I'm not seeing any water after a few loads I'm assuming that means I need a new pump. Does that seem reasonable?

Thanks for all your help, Jake.

** EDIT **
So far, so good. Dryer has been running for 20-30 minutes with no error codes. Peeking at my drain bucket, I saw water actively being pumped out and there's probably about 100 mL of water collected so far, so it seems like the pump does still work. Fingers crossed it keeps working. I'll update accordingly if I run into more trouble.
Last edited:
Further update:

Dryer worked perfectly for 1 load. When I ran a second load, I did not see any more water get pumped out into my bucket, and after running for about 45 minutes, received the F9E2 code again. I'm assuming the pump is bad and is only working intermittently (and much less frequently than when the problem first started showing up).

Before I place my order, do you think the reasonable next step is to replace the pump and see if it resolves the issue? I have a part number of W10608847, looks like there's an updated part W10903190, so hopefully they've improved upon the initial design...
Sounds like your making good progress, yes its possibly that drain pump that's intermittently working and not working.

In the service manual TEST 9: Drain System Page 6-20

Did you locate that drain pump part number on the drain pump itself, because I don't see it listed in the parts diagram: https://drive.google.com/file/d/1GiIm1VS5c68LmcnuK5oeUvWCZbXie0vJ/view?usp=sharing

Yes, W10608847 changes to W10903190:

Did you locate that drain pump part number on the drain pump itself, because I don't see it listed in the parts diagram:
Yes, the part number is on the drain pump. I'll attach a picture of it that also shows the water that leaked out from the tubing when I blew on it a few days ago. I still wonder if the tubing not being fully seated could be messing things up.

I found a new/open box housing + float + pump on ebay. Most everywhere else just sells the pump itself, and I'm pretty sure I'd break the housing trying to get the old one out. I purchased the more extensive part for simplicity and also in case the float actually is the problem.

In the tech manual, if I'm reading it correctly, I've gone through almost everything with no luck. I skipped the step about checking connections, as I double checked all that when I installed the new user control last week. Time to replace parts, it seems. I'm on the second to last step: replacing the pump. If issue persists, CCU is next.

Ok, got it!

Let us know how it goes when you get the parts.

Got the new part today and installed it a few minutes ago. Super easy fix. I'm glad I found the entire assembly, rather than just the pump as it was just 1 nut, take old part out, put new part in. Probably won't know for sure until this weekend if it's fixed, but so far load #1 is running as it should.
Thanks so much for your informative posts, neverwpool and Jake! Recently ran into the same error F9E2 with our Whirlpool WHD560CHW2 Heat pump dryer that we've had for nearly 2 years. The solution was probably just to unclog the drain hose, but I took it upon myself to disassemble the whole thing to try to clean the condenser fins which were looking a bit linty. It wasn't nearly as linty as I expected once I got in there, but I agree with other posters that the engineering of the lint handling in this machine needs some work. I probably should have checked the reservoir while I had it disassembled, but didn't do so.

In the disassembly, I found a few things I thought I would note here in case anyone else decides to undertake and runs into similar issues:

1 - When removing the heat exchanger cover as part of the Reed Lint Switch removal (4-14 in the manual noted in Jake's post above) I discovered that a single screw in the back had been installed incorrectly from the factory which was preventing a good seal with the heat exchanger and the bulkhead (see the Reassembly notes at the end of the 4-19 step in the manual). The screw missed the receiver hole in the plastic, leaving a gap between the seal and the bulkhead. This meant I had to take off the back cover as well to access and reattach the screw properly.
2 - When removing the plastic blower wheel in step 7 of 4-12 (which I needed to do before removing the heat exchanger cover in 4-14), the 5/8" socket wrench placed over the plastic nut was very difficult because the nut was basically stripped, though it had never been worked on. Just a flaw in design that made it very "slippery". I had to place 2 layers of rubber (from dishwashing gloves) sandwiching a paper towel over the nut before putting the socket wrench on, and even then had to pull on the blower fins to actually loosen the wheel. I thought this was going to be the end of the disassembly because it was so hard. But eventually it gave way and led to my only injury of the entire process - a small scrape of the hand.
3 - Upon reassembly, I noted a small gap between the felt drum seal and bulkhead, but I couldn't figure out how that might have happened, or if it was present before disassembly. Any idea if this is normal? (see photo) There is no damage to the felt.

So far we haven't had a repeat of the error. Only one load of laundry dried so far. I imagine the better seal for the heat exchanger is improving the efficiency. Hopefully, the gap in the drum seal isn't making that moot.

Thanks again for the links to the manuals and the detailed trouble shooting. Was very helpful in attempting to tackle this.


  • IMG_3298.jpg
    120.5 KB · Views: 154
  • IMG_3302.jpg
    85.6 KB · Views: 158
  • IMG_3303.jpg
    47 KB · Views: 156
I discovered that a single screw in the back had been installed incorrectly from the factory which was preventing a good seal with the heat exchanger and the bulkhead (see the Reassembly notes at the end of the 4-19 step in the manual). The screw missed the receiver hole in the plastic, leaving a gap between the seal and the bulkhead. This meant I had to take off the back cover as well to access and reattach the screw properly.
Excellent, good find.(y)

Thanks for posting the steps that you did, that will help others too.:)
Hi Jake & neverwpool! I want to thank you both for this thread, and for the precise troubleshooting/directions that you provided. We had the same error codes on our 14 month old dryer. Fortunately, we bought an extended warranty, but they didn’t want to come out and fix it, so they just cut us a check for the purchase price. We couldn’t find any local technicians to come fix it so we thought we would try it ourselves. Based on your recommendations, we bought the entire pump assembly and installed it yesterday. We dried a load of laundry with no problems and no error codes. We probably won’t know for sure if it’s fixed until we’ve done several loads— to give the reservoir a chance to fill up in the event that the new pump is not working (or in the event that something else is wrong). But so far so good! The price of the pump assembly was way less than our refund check so if this works, we will be way ahead of the game! thank you so much for this post!
Sounds good tptully, glad to hear that.(y)

Thanks for letting us know!
Well, we're back in intermittent error world with our dryer. It basically throws the error if we try to dry more than one load. I finally took the steps that neverwpool suggested, removed the back panel and taking the entire pump and float assembly off the top of the reservoir. I found the reservoir completely full. I used a wet dry vac to empty and wiped out the reservoir. A little gunky but not nearly as bad as I expected. I simply put the pump and float back in and reconnected everything. I'm pretty sure I could hear the pump cycling on when I started the dryer. Not sure if this happens when the cables are disconnected and reconnected as part of its internal protocols. Anyway, now we wait and see if it throws the error again, at which point we'll order the assembly linked above. I wonder if anything has changed in the updated part.
Thanks to everyone for solving my Whirlpool WHD560CHW heat pump dryer breakdown. At least I purchased the Home Depot 5 year extended warranty. I never buy the extended warranty but it was the only full size heat pump dryer that was available and had a very low reliability rating from Consumer Reports. When the warranty company sent me the control board to fix the problem the tech and I agreed that it wasn't the problem based on this forum. It was the pump assembly that failed. He reordered the part and installed the new one today. Works like a charm now. Although I find it hard to believe that Whirpool is selling a dryer that has a part in it that fails after 15 months of use. I hope this one doesn't fail but if it does I know how to fix it in the future.
Exactly! Now that we know how to fix it, it will be much easier next time (if it does fail)! Glad to hear it worked for you. This forum is fantastic!

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.