• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Whirlpool Dishwasher WDF330PAHB0 not heating..

Status
Not open for further replies.

Rubberman

Premium Member
Joined
Dec 25, 2020
Messages
14
Location
Indiana
Model Number
WDF330PAHB0
Brand
Whirlpool
Age
6-10 years
Replaced the bottom heating element since it was bad. Tested the continuity of the new heating element and the existing high limit stat and both are good. Dishwasher is not getting hot or steamy. Dishes stay wet after cycle. The only thing left i would think is a bad control board?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Hi,

Anytime you replace a part on these dishwashers you always have to run the SERVICE DIAGNOSTICS CYCLE, and let it run all the way through to reset it back to default.

Entry sequence: Press any 3 keys in the sequence 1-2-3, 1-2-3, 1-2-3 with no more than 1 second between key presses. NOTE: Some models have replaced the “Clean” LED with “Completed.”
The Service Diagnostics Cycle will start when the door is closed.

--->Invoking Service Diagnostics clears all status and last run information from memory and restores defaults. It also forces the next cycle to be a sensor calibration cycle.

LET IT RUN ALL THE WAY THROUGH: Service diagnostic cycle will take about 23 minutes.

Do that and run a cycle and see if it starts heating.:)

Jake
 

Rubberman

Premium Member
Joined
Dec 25, 2020
Messages
14
Location
Indiana
I think the diagnostic service mode corrected the issue. Seems to be working correctly and getting steamy. Thank you
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,647
Location
Redmond, Oregon
Excellent, glad to hear that.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top