• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Whirlpool Gold GI0FSAXVY02 - front display 8's, not cooling

jajakoo

Premium Member
Joined
May 27, 2019
Messages
6
Location
Montreal
Model Number
GI0FSAXVY02
Brand
Whirlpool
Age
6-10 years
Request your assistance.
Posts used for references and precise details are below.

I unplugged my GI5FSAXVY02 for a few minutes while I was cleaning the coils underneath (coming from back/below). When plugged back in, the frige made a rapid clicking noise for a few seconds and when it stopped, the display was dark - pressing any button lights the entire control panel. I could not enter programming mode, the interior light worked and there was no cooling. Pressing the freezer temp up/down made the ice flap open and close.

While still plugged-in, about 48 hours later, the frige started working correctly again. I had done nothing to it in that time. About 2-3 days after that, the exact same shenanigans started again. Given that the voltages are correct and all of the buttons work and lights light, it seems like I should replace the dispenser control board because (it appears to me) the Main board is controlling the voltage, and the dispenser control board the "brains" running the whole thing (???)

I've read many posts here (more found here than any other site!!).
https://www.applianceblog.com/mainforums/threads/64770-Whirlpool-Gold-GI0FSAXVY02-Front-Display-Panel-showing-all-8-s-when-any-key-is-pressed?highlight=gi5fsaxvy02

https://www.applianceblog.com/mainforums/threads/54532-Whirlpool-GI5FSAXVY02-Front-display-went-out-Fridge-quit-cooling-and-dispensers-quit-working?highlight=gi5fsaxvy02

https://www.applianceblog.com/mainforums/threads/28985-GI5FSAXVY02-Whirlpool-Refrigerator-Control-Panel-on-door-doesn-t-work

https://www.applianceblog.com/mainforums/threads/61858-GI5FSAXVY02-Whpl-fridge-won-t-go-into-program-mode-after-replacing-control

Tried:
Cannot get to program mode (as described by Rickgburton in above thread).
Power off (reset?) for >60 min. No change.
No indications of pinched wires at the hinge of the door seen
Disconnected and re-connected all of the connectors on both boards.

Voltage measurements:
High Voltage (Main) Control Board: https://www.appliancepartspros.com/whirlpool-board-hv-control-wpw10310240-ap6019229.html
J1-Pin 4 and J1-Pin 8 = 124 Volts AC
J6-Pin 2 and J6-Pin 1 = 13 Volts DC

Dispenser Control Board: https://www.appliancepartspros.com/whirlpool-cntrl-elec-w10740218-ap5953018.html
J1-Pin 1 and J1-Pin 3 = 13 Volts DC

Thank you for any information, guidance, etc. you can provide.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
111,070
Location
McMullen Valley, Arizona

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
111,070
Location
McMullen Valley, Arizona
Excellent jajakoo, glad to hear the main control board fixed it.:)

Thanks for the update!

Jake
 
Top