• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Whirlpool Refrigerator GI7FVCXWY03 ice maker not filling with water

Status
Not open for further replies.

PokeChop

Premium Member
Joined
Jul 6, 2022
Messages
3
Location
OH
Model Number
GI7FVCXWY03
Brand
Whirlpool
Age
More than 10 years
Hi applianceblog members!

We have a 12 year old Whirlpool GI7FVCXWY03 that has made thousands of ice cubes for us over the years and just stopped making ice yesterday.

I'm a DIY type and did a lot of online research trying to troubleshoot the issue. This site has a lot of great information!

It seems the ice maker is not filling with water. I took off the plastic cover piece and removed the ice maker. There is no ice buildup anywhere, the fill tube coming from the top of the refrigerator isn't frozen, and the ice cube tray is bone dry.

So I reinstalled the ice maker and pressed and held the TEST SWITCH for a good 30 seconds and nothing happened. Then I entered Diagnostic mode and attempted Test 18 ICE MAKER FILL TEST. I selected Test 18 on the screen and then held down the TEST SWITCH for another 30 seconds and nothing happened. It just reads "Ice Maker Fill OFF".

I came across the thread below in my research. In post #21 of the thread linked, it sounds like if you press and hold the TEST SWITCH and nothing happens, then the maker is bad. Does this sound correct to you experts?

Other Whirlpool Thread link

If so, can you link me to the correct ice maker I need to order?

Thanks so much for the help, I appreciate it!

Eric
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon

PokeChop

Premium Member
Joined
Jul 6, 2022
Messages
3
Location
OH
Thanks Jake! I'll go ahead and order a new one from you guys.

Do I just use the wiring harness from the old unit?

Eric
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
Yes Eric, use the wiring harness from the old unit.

Let us know how it goes.

Jake
 

PokeChop

Premium Member
Joined
Jul 6, 2022
Messages
3
Location
OH
Hi Jake - I'm back up and running! Took about a half hour to replace the ice maker and it's running 100% again. Thanks for the help!
Eric
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
Excellent Eric, glad to hear the new ice maker fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
If you feel that you have benefited from this site, and would like to show your appreciation.
Top