• Please note, some of the links on our site are affiliate links (Learn More)

Whirlpool refrigerator W4TXNWFWQ03 freezer at 0, fridge too cold, almost constantly runs and frost buildup

Jennifer B

Premium Member
Apr 10, 2021
Model Number
6-10 years
My last fridge was deemed to be a sealed system problem, so I purchased a used one to replace it. BAD idea. It worked great to begin with, but noticed there seemed to be more condensation (everything looked fogged up) inside the fridge most of the time.

The freezer also seemed to be a little extra frosty, but was hoping that was just how this fridge worked. Well after about 4 weeks, the fridge would almost constantly run, the fridge was starting to freeze water, the freezer was staying between 0 and 10 and then the motor? fan? started to make a ticking noise, that was constantly getting louder, which was similar to the sound my previous fridge was making and it turned out to be a the fan hitting frost buildup.

So I decided to defrost it and hope that fixed it. And it did, for a couple weeks. There didn't appear to be any frost in the way of the fan, it moved easily, however after I turned the fridge back on, the noise was almost gone. But now the same thing is happening again. Any idea what might be wrong and it if it could be fixed?

Attached pictures are after only about 5 weeks of the fridge running.


  • IMG-1127.JPG
    145 KB · Views: 231
  • IMG-1131.JPG
    245.2 KB · Views: 214
  • fridge1.jpg
    147.2 KB · Views: 272
Hi, It sounds like you have a part that's bad which controls your defrost cycle. I would start by turning your defrost timer clockwise with a flathead screwdriver, turn it slowly till your refrigerator shuts off, then it will be in the defrost cycle, give it about 5 minutes to see if your defrost heater comes on, the defrost heater is located under your evaporator coil in your 2nd photo above. Feel for heat there after 5 minutes.

Your defrost timer is #4 here:
(click to enlarge)

There is a hole just under your console#12 that you can put your flathead screwdriver in to turn the defrost timer clockwise slowly, without having to remove the console itself.

Here is the defrost timer for your model:
W10822278 Defrost Timer

Report back what you find.

Had to turn it quite a bit, but it turned off, and there was heat after a few minutes. I can hear dripping water now.
Ok, that indicates your defrost thermostat and defrost heater are working fine. So that just leaves the defrost timer as the culprit, you can order it from post #2.

That is great news! Thank you so much! Is that something I can replace on my own without any special tools?

Watch this video below, it should be similar to your model:

Let us know how it goes.

Hi Jake,

I finally got around to installing the new timer last month. I had been manually putting the fridge into defrost at least once a week and that seemed to keep it working well. The timer was easy to replace, but it doesn't seem to be working. I haven't manually put the fridge into defrost since replacing the timer about a month ago. The same thing seems to be happening. Fridge is almost constantly running, freezer stays between 0 and 10, fridge is hovering just above freezing and there's lots of condensation on everything. I know it's a little more humid this time of year, but I'm pretty sure it's more than that. Any ideas on what might be going on? There wasn't much to connecting the new timer, but could I have messed that up somehow? Any ideas would be appreciated, thanks!
fridge is hovering just above freezing and there's lots of condensation on everything.
That indicates you have a air leak coming in, check the door gaskets for a tight seal ALL AROUND the refrigerator door.

Put the defrost timer into defrost manually and let it defrost, it should take about 20 to 40 minutes then see if the timer kicks out of defrost by-itself and goes back to cooling mode.

It doesn’t look like there’s anywhere that would be leaking.

I left it in the defrost mode for 45 minutes and it didn’t kick itself out of it, but I was able to turn the dial and it started back up again. Just defrosting it that once it seems to be working much better now. Any ideas on why the timer isn’t working? I’ve attached a couple photos. Not sure that helps at all


  • 5BE6BF03-F2B3-4D1D-9553-A2E33E7D2E8F.jpeg
    323.8 KB · Views: 83
  • A0122391-3CBB-4EA9-B6E0-DBECE49B801E.jpeg
    291.1 KB · Views: 74
Lets make sure you have it wired right.

Look at this diagram below:

1Screenshot 2022-06-07 08.20.58.png

2Screenshot 2022-06-07 08.26.01.png

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.