• Please note, some of the links on our site are affiliate links (Learn More)

Whirlpool refrigerator WRX988SIBM01 the freezer does not cool properly

Stewdog

Premium Member
Joined
Feb 7, 2022
Messages
2
Location
Ny
Model Number
WRX988SIBM01
Brand
Whirlpool
Age
6-10 years
I have a 2015 refrigerator and the freezer does not cool properly, it stays from 10 to 20⁰. I have good frost through the fridge evaporator and freezer evaporator, all of the fans are running and condenser is clean. I have 3psi on the suction line on the compressor. My fridge stays nice and cold but it seems the freezer cools when it wants. When I plug in the fridge after sitting a while, the fridge starts cooling, then 10 minutes later the freezer evaporator starts to get freon and kicks the fan on. Does this sound like a bad 3 way valve or thermistor? Thank you
 

Robert4

Premium Member
Joined
Jun 5, 2021
Messages
243
Location
Houston, TX
You should have a light, even layer of frost across the entire evaporator coil. Take the evaporator cover off and check the frost pattern on the coils. Take a picture and post it here.
 

Stewdog

Premium Member
Joined
Feb 7, 2022
Messages
2
Location
Ny
You should have a light, even layer of frost across the entire evaporator coil. Take the evaporator cover off and check the frost pattern on the coils. Take a picture and post it here.
 

Attachments

  • IMG_20220209_073925_HDR.jpg
    IMG_20220209_073925_HDR.jpg
    261.4 KB · Views: 76

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,231
Location
Redmond, Oregon
Looks like a even frost pattern to me.

Put the evaporator cover back in place and as long as the evaporator fan motor is running it should get to 0 degrees F in the freezer.

Jake
 
Top