• Please note, some of the links on our site are affiliate links (Learn More)

Whirlpool washer WTW6400SW2 does not spin


Premium Member
Jul 12, 2017
Quebec City, Canada
Model Number
More than 10 years

I believe I had the same error code that was covered by the warranty a few years ago but I don't know if this is the same problem coming back or a new one related to the same F50 error code. The washer locks, starts pulling water into the basket, stops, starts pulling more. Pretty much like it always does when it starts a wash. Then, it should spin but it does not and spits out error code F50. I searched on Google but couldn't find the repair manuel. I found it for various other similar washer models but not WTW6400SW2 precisely. This is the model number written on the same sticker as the serial number.

I suppose I should run some diagnostics but I don't know how to enter that mode with this washer model. How could I do this? I also am willing to replace parts but it will depend on how much it is and how worth it is to do it considering how old our washer is (a bit more than 10 years old now). We could also use the option to call a technician but I would like to see how far I can go myself to save some money. We're trying to minimize how much we purchase and spend and starts to embrace zero waste principles and such so being able to do the repair myself would definitely be a plus!

I would appreciate any help to diagnose and fix our problem!

Thank you very much!


I spent more time to figure out the issue with our washer. I was able to find a manual that seems to cover how it works. I took time to read and learn how the washer works from a high-level point of view. Here is what I did in case someone has an idea what could be wrong to help us out:

- I entered automatic diagnostics and the test to spin the basket (C1) failed.
- I went into manual diagnostics and locked the lid. The test to spin the basket also failed. However, the basket can move freely. I can spin it manually and see the light indicators change as I spin it clockwise or counterclockwise. I believe this means the RPS sensors are good. Please, tell me if I am wrong here.
- I played a bit with the valve/pump tests to figure out how they work and filled the basket with fresh water for a few minutes until it seems like the basket disengaged. This was to prepare the agitate test.
- I started the agitate test and nothing happened. I started moving the basket around and it suddenly started agitating. I tried all agitation modes and they all worked.
- I went back to the spin test so I closed the lid, locked it and started the test. This time, the basket started to spin. I moved on to higher speeds but not for too long as I don't know what is the root issue. I stopped the spin and it slowed down to a halt.
- I drained the water using the valve tests.

What can I deduce from the tests? Does it mean there could something blocking inside like a garment? I did not open the washer yet but this is my next step to do a visual inspection. Does anyone ever encountered an issue like this?


Hi David,

I believe these are the repair manuals for the Cabrio you own:

Cabrio washer with 6th sense: https://www.applianceblog.com/manuals/Cabrio6th.pdf

Cabrio washer: https://www.applianceblog.com/manuals/Cabrio_Washer.pdf

You may have a cracked rotor or stator, I'd check that first.

Here's the rotor for your model:
Rotor Assembly 280146

<iframe width="496" height="304" src="https://www.youtube.com/embed/-6v_k9iK7gY" frameborder="0" allowfullscreen></iframe>

Here's the stator for your model:
Stator Assembly W10419333

<iframe width="496" height="304" src="https://www.youtube.com/embed/KTBb-hTkq1w" frameborder="0" allowfullscreen></iframe>

Here's another thread on this error code: https://www.applianceblog.com/mainforums/threads/20428-WTW6600SW0-Whirlpool-Cabrio-Washer-F50-Error

Hi Jake,

Before I tilt the washer forward, how could I ensure there is no water left that could spill on the floor? After I get the washer to drain water for a few minutes and spin the basket manually, I still hear there is water underneath. Should we pull the basket and clean up all water inside before we tilt it forward?


Ok David,

How long does it take the washer to drain? That may be the problem, it should take no longer than 90 seconds to drain.

If its taking longer than 90 seconds, First check for a clog in the drain pump, that would cause this issue.

Here's the drain pump for your model:
Drain Pump W10536347

Watch this video to access/replace it.

Hi Jake,

I spent some more time today on the problem and after pulling the basket, there wasn't much water left. I did go into diagnostics right before I disassembled the parts and had the drain pump run for 90 seconds just to be sure not much water would be left to clean up.

After visual inspection of the couple additional parts I could see, nothing really stands out. I cleaned the tub and still have a few parts to clean. I thought it wouldn't hurt anyways. There was nothing special in the lint filter either.

I also pulled the console and checked the various electrical connections and went through a couple steps of TEST #3. Still, no tip that helps point where the problem is.

After pulling the basket, I figure the "water" I heard was actually a liquid in the basket assembly. What is that for? I cannot tell if it is really water or not but it seems to be inside the basket part and there is no obvious way to take it out. Is it for balance or weight?

Next step is to remove the water connections and tilt the washer forward to look underneath and see if anything stands out with the rotor or stator based on your suggestion.

I heard was actually a liquid in the basket assembly. What is that for? I cannot tell if it is really water or not but it seems to be inside the basket part and there is no obvious way to take it out. Is it for balance or weight?
Yes, for balancing.

Sounds like your making progress David.

If you feel that you have benefited from this site, and would like to show your appreciation.