• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Whirlpool WDT790SAYM3 Dishwasher- Clicking Noise But Not Cleaning

Status
Not open for further replies.

jakeman21co

Premium Member
Joined
Apr 16, 2022
Messages
2
Location
Denver
Model Number
WDT790SAYM3
Brand
Whirlpool
Age
6-10 years
My dishwasher isn't working. The dishwasher fills, and empty's fine but the when I'd expect to hear the water spraying I just here clicking, like a motor or pump should be turning on and off. I tried running the diagnostic cycle. I believe it ends with beeping, but when it beeps I open the dishwasher and there's no LED's on, so I don't see an error code.
  • Am I not letting the diagnostic cycle fully run?
  • Has anyone had a problem like this before?
I appreciate any and all help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
131,334
Location
Redmond, Oregon
Yes, It's most likely a bad wash motor, this has become a common problem as of late, many members here have reported the same. In fact I had 2 do this same thing in Sept. 2018 in Parker, Arizona, and the new wash motor fixed them both.:)

Look at post #7 here: FIXED 665.13472N411 What to check on why it only washes about 5% of the cycle.

I'd first check to see if your getting 120 volts to the wash motor when it should be in the wash cycle. His Kenmore 665 made by Whirlpool, and uses the exact same wash motor yours does.

Take the wire connector off the wash motor and use your multimeter to see if yours is getting 120 volts when it should be washing, if so and it's not running order the wash motor below.

Here is the wash motor assembly for your model:
W11032770 Motor-Pump


Here's the video:

Or, you can order the complete assembly which comes with the wash motor already installed for you along with a new diverter motor too that's less expensive:
PUMP&MOTOR WPW10605057


Let us know what you find.

Jake
 

jakeman21co

Premium Member
Joined
Apr 16, 2022
Messages
2
Location
Denver
Thanks Jake!
That did the trick. The replacement wasn't to bad, only took 20ish min start to finish and my dishwasher is running normally now. Thank you for the help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
131,334
Location
Redmond, Oregon
Excellent @jakeman21co glad to hear that.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top