• Please note, some of the links on our site are affiliate links (Learn More)

Whirlpool WFE550S0HZ not holding temp (sometimes not working at all)

222

Member
Joined
Dec 9, 2019
Messages
1
Location
Earth
Model Number
WFE550S0HZ
Brand
Whirlpool
Age
1-5 years
My new-ish Whirlpool is not working. Bought it May of 2018.

It seems to be doing 2 different things - both annoying but one makes the oven downright unuseable.

1) When the oven hits temp - it does not hold temp. So every 5-10 minutes I have to cancel it and re set the temp again so that it will go back up. Pretty annoying for a new-ish appliance but not the end of the world.

2) Sometimes when I cancel and reset the temp it won't go up at all. So say I preheat the oven to 400 - 10 minutes later I cancel it and re-set it to 400. When I do that the oven will read something like 360 to show that is the current temp and then (hopefully) work it's way back to 400. However more and more lately when I cancel and reset it it won't go up again at all. So I'll cancel and re-set it again and again trying to 'catch' it during a cycle where it will actually go up again. It's gotten so bad lately I've had to throw away many half cooked meals.

If it was just issue #1 I could deal with it. But with issue #2 it makes the oven completely unuseable.

I know very little if anything about appliances. What are my options? It's been 1 year and 7 months since I bought it. Will Whirlpool be any help if I try to get in touch with them? I purchased the Oven from Best Buy - can they help me with anything? Should I find a local repair place?

Any advice is welcomed, thanks.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,240
Location
McMullen Valley, Arizona
Hi,

It sounds like your oven sensor or oven control board is faulty. Its best to have a Whirlpool tech. come out.

Are you in Canada? If so, Contact Whirlpool in Canada at 1-800-807-6777 to have a Whirlpool tech come out.

Jake
 
Top