• Please note, some of the links on our site are affiliate links (Learn More)

Whirlpool WRF767SDHZ00 Refrigerator can't get freezer LED out


Premium Member
Aug 29, 2018
Model Number
1-5 years
I'm having the same LED issue as numerous other posters here, with the freezer LED and fridge top LED out but all others lit. I'm trying to remove the freezer LED as instructed and shown in the video for the LED board but it feels like it's soldered in place or something. First I tried with a flexible putty knife as shown in the video, but the resistance from the LED was so great that I snapped it in half. Now I'm trying with a thicker metal scraper and there is absolutely no give whatsoever. I pushed the scraper in between the LED unit and the freezer housing and moved it all around to break any frozen condensation that may be keeping it in place. The plastic housing around the LED is all mangled now from me trying to get it loose, but I haven't felt even the slightest budge. Attached is a video of me making an attempt with the scraper--I've also tried coming in from the back side with the same results.

Any tips on how to get this mother out?

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.