• Please note, some of the links on our site are affiliate links (Learn More)

Whirlpool WRT518SZFM00 refrigerator not cooling/wont go into diagnostic mode

JD.B

Member
Joined
May 24, 2022
Messages
1
Location
Kearns UT
Model Number
WRT518SZFM00
Brand
Whirlpool
Age
1-5 years
Hello. So I started to notice that our freezer wasn’t working properly. Ice cream wouldn’t stay frozen. Fridge doesn’t seem as cold as it should be either. Cleaned the small set of coils in the back of the fridge. Fan in back and the compressor seem to be working properly. Fan in freezer comes on. Had continuity on the heating element. Went to try the diagnostic mode and I can’t get it to work. Basically a temp switching button and 4 LEDs.

It says to turn it to the lowest temp and press the button and the door switch for 5 seconds. You are supposed to release when all lights turn on. It doesn’t matter how long I hold the button and door switch or which I push first or at the same time. Nothing happens. No lights. No clicking. Can anyone point me to what I’m doing wrong? This fridge is like 3 1/2 years old is all and we bought it brand new. Any help would be much appreciated. Thanks in advance.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,675
Location
Redmond, Oregon
I'm attaching your tech. data sheet below, try it again, you may have missed a step.

But if the freezer evaporator fan motor is running and condenser fan motor and compressor are running, you should have a thin layer of frost on all the coils from Top to Bottom.

I'd remove the back panel inside the freezer and take a photo of the frost pattern of your evaporator coil, so we can see if its good or not.

Look at the very bottom photo below, it says NORMAL FROST PATTERN, That's what yours should look like.

Frost Patterns.jpg
 

Attachments

  • techsheet-w10843219-reva.pdf
    730 KB · Views: 108
If you feel that you have benefited from this site, and would like to show your appreciation.
Top